HDU 1892 See you~ 二维树状数组

See you~

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2023    Accepted Submission(s): 645


Problem Description
Now I am leaving hust acm. In the past two and half years, I learned so many knowledge about Algorithm and Programming, and I met so many good friends. I want to say sorry to Mr, Yin, I must leave now ~~>.<~~. I am very sorry, we could not advanced to the World Finals last year.
When coming into our training room, a lot of books are in my eyes. And every time the books are moving from one place to another one. Now give you the position of the books at the early of the day. And the moving information of the books the day, your work is to tell me how many books are stayed in some rectangles.
To make the problem easier, we divide the room into different grids and a book can only stayed in one grid. The length and the width of the room are less than 1000. I can move one book from one position to another position, take away one book from a position or bring in one book and put it on one position.
 


 

Input
In the first line of the input file there is an Integer T(1<=T<=10), which means the number of test cases in the input file. Then N test cases are followed.
For each test case, in the first line there is an Integer Q(1<Q<=100,000), means the queries of the case. Then followed by Q queries.
There are 4 kind of queries, sum, add, delete and move.
For example:
S x1 y1 x2 y2 means you should tell me the total books of the rectangle used (x1,y1)-(x2,y2) as the diagonal, including the two points.
A x1 y1 n1 means I put n1 books on the position (x1,y1)
D x1 y1 n1 means I move away n1 books on the position (x1,y1), if less than n1 books at that position, move away all of them.
M x1 y1 x2 y2 n1 means you move n1 books from (x1,y1) to (x2,y2), if less than n1 books at that position, move away all of them.
Make sure that at first, there is one book on every grid and 0<=x1,y1,x2,y2<=1000,1<=n1<=100.
 


 

Output
At the beginning of each case, output "Case X:" where X is the index of the test case, then followed by the "S" queries.
For each "S" query, just print out the total number of books in that area.
 


 

Sample Input
2 3 S 1 1 1 1 A 1 1 2 S 1 1 1 1 3 S 1 1 1 1 A 1 1 2 S 1 1 1 2
 


 

Sample Output
Case 1: 1 3 Case 2: 1 4
 代码:
#include<string>
#include<stdio.h>
#define lowbit(x) ((x)&(-(x)))
using namespace std;
#define N 1005
int map[N][N],com[N][N];
void update(int x,int y,int p)
{
    int k;
    while(x<N)
    {
    k=y;
    while(k<N)
    {
       map[x][k]+=p; 
    k+=lowbit(k);  
       }    
       x+=lowbit(x);
    }
}
int query(int x,int y)
{
    int sum=0;
    for(int i=x;i>0;i-=lowbit(i))  // 用while超时;
        for(int j=y;j>0;j-=lowbit(j))
            sum+=map[i][j];
    return sum;
}
int main()
{
    int T;
    int cnt=1;
    scanf("%d",&T);
    while(T--)
    {
        printf("Case %d:\n",cnt++);
        memset(map,0,sizeof(map));
        memset(com,0,sizeof(com));
        for(int i=1;i<N;i++)
            for(int j=1;j<N;j++)
            { 
                update(i,j,1);
                com[i][j]=1;
            }
        int n;
        scanf("%d",&n);
        while(n--)
        {
            char s[3];
            scanf("%s",s);
            if(s[0]=='S')
            {
                int x1,y1,x2,y2;
                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
                 x1++;y1++;x2++;y2++; //防止lowbit(0)死循环;
                if(x1>x2)
                    swap(x1,x2);
                if(y1>y2)
                    swap(y1,y2);
                printf("%d\n", query(x2,y2)-query(x1-1,y2)-query(x2,y1-1)+query(x1-1,y1-1));
            }
            else if(s[0]=='A')
            {
                int x,y,p;
                scanf("%d%d%d",&x,&y,&p);
                x++;y++;
                update(x,y,p);
                com[x][y]+=p;
            }
            else if(s[0]=='D')
            {
                int x,y,p;
                scanf("%d%d%d",&x,&y,&p);
                x++;y++;
                update(x,y,(com[x][y]-p<0?-com[x][y]:-p));
                com[x][y]=(com[x][y]-p<0?0:com[x][y]-p);
            }
            else if(s[0]=='M')
            {
                int x1,y1,x2,y2,p;
                scanf("%d%d%d%d%d",&x1,&y1,&x2,&y2,&p);
                x1++;y1++;x2++;y2++;
                if(com[x1][y1]>p)
                {
                    update(x1,y1,-p);
                    update(x2,y2,p);
                    com[x1][y1]-=p;
                    com[x2][y2]+=p;
                }
                else
                {
                    update(x1,y1,-com[x1][y1]);
                    update(x2,y2,com[x1][y1]);
                    com[x2][y2]+=com[x1][y1];
                    com[x1][y1]=0;
                }
            }
          }
    }
    return 0;
}
 

转载于:https://www.cnblogs.com/hebozi/archive/2012/08/05/2624242.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值