Shuffle'm Up POJ - 3087(模拟)

Shuffle'm Up
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15249 Accepted: 6962

Description

A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

Output

Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

Sample Input

2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC

Sample Output

1 2
2 -1

Source

题意:先给你两个长度一样的初始状态字符串s1,s2和一个大小为两倍的最终状态的s12,按照s2的第一个先放在s12第一个再依次是s1,s2,s1…,排完后再按照长度前一半是s1新状态,后一半是s2新状态, 重复以上操作,看得到s12是否有和 最初给的最终状态的s12相同的,有输出步数,没有就输出-1.

思路:按照题目的顺序模拟即可,可以将每一个整合后的一个新的S12放进一个map里面,接下去如果模拟到了目标串就输出,如果发现模拟到的一个s12在map中出现过了并且不是和目标串的一样的话,那么这个时候出现了一个循环,无论如何也模拟不出目标串了,就可以输出-1了。注意那个'\0',一开始没有加这个wa了好几发。

 

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<queue>
#include<set>
#include<map>
#include<vector>
using namespace std;
#define INF 0x3f3f3f3f
#define eps 1e-10
#define PI acos(-1.0)
#define _e exp(1.0)
#define ll long long
const int maxn=1e6+5;

char a[maxn];
char b[maxn];
char c[maxn];
char goal[maxn];
int main()
{
    int t;
    scanf("%d",&t);
    int ca=1;
    while(t--)
    {
        int n;
        int step=0;
        scanf("%d",&n);
        scanf("%s%s",a,b);
        scanf("%s",goal);
        map<string,int>mp;
        mp[goal]=1;
        while(1)
        {
            
            int pos=0;
            for(int i=0;i<n;i++)
            {
                c[pos++]=b[i];
                c[pos++]=a[i];
            }
            c[pos]='\0';
            step++;
    //        for(int i=0;i<2*n;i++)
    //            cout<<c[i];
            if(strcmp(c,goal)==0)
            {
                cout<<ca++<<" "<<step<<endl;
                break;
            }
            else if(mp[c]==1 && strcmp(goal,c))
            {
                cout<<ca++<<" "<<-1<<endl;
                break;
            }
            mp[c] = 1;
            int ii,k;
            for(ii=0;ii<n;ii++)   //分拆出s1与s2
                a[ii]=c[ii];
            a[ii]='\0';
            
            for(k=0;ii<2*n;ii++,k++)
                b[k]=c[ii];
            b[ii]='\0';

        }
    }
}

 

转载于:https://www.cnblogs.com/smallhester/p/9603976.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值