[kuangbin带你飞]专题1 简单搜索 G - Shuffle'm Up POJ - 3087

题目:

Shuffle'm Up
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12827   Accepted: 5947

Description

A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

Output

Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

Sample Input

2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC

Sample Output

1 2
2 -1


题意:

有s1,s2两摞牌,每次洗牌都会让s2的最后一张放在shuffle序列的最底部,s1的最后一张牌放在上面,s2的倒数第二张继续放在上面。s1的最后一张牌继续放在上面……s2的第一张牌继续放在上面,s1的第一张牌放在shuffle序列的最上面。

洗完牌后将shuffle序列底部的C张牌当作s1,剩下的牌当作s2,继续进行洗牌的操作。

先输出第几个case,

当洗牌的结果与给定s12序列的结果相同时,输出洗牌次数。否则输出-1。

(输入的序列都是从底部开始的)


思路:记录每次结果,如果洗牌的结果之前已经得到过,就不可能得到目标序列。否则继续洗牌操作直到得到目标解。

这题算搜索吗。。。感觉是模拟a


#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<stack>
#include<set>

typedef long long ll;

using namespace std;

set<string> se;     //如果一个序列已经被洗牌的操作得到过,就加入set 

int main(){
	ios::sync_with_stdio(false);
	int t;
	string s1;
	string s2;
	string aim;
	
	int cases = 1;
	
	cin>>t;
	while (t--){
		int c;
		cin>>c;
		cin>>s1>>s2;
		cin>>aim;
		
		int ans = 0;
		bool flag = 0;
		while (1){
			string now;
			for(int i = 0 ; i<c ; i++){
				now += s2[i];
				now+=s1[i];
			}
			if(se.find(now)!=se.end()){  
				break;
			}//若这个序列曾今被找到过,就退出,因为将陷入循环,永远无法得到目标的序列 
			
			ans++;
			se.insert(now);
			if(now == aim){
				flag = 1;
				break;
			}
			for(int i = 0 ; i<c ; i++){
				s1[i] = now[i];
				s2[i] = now[i+c];
			}
		}

		if(flag){
			printf("%d %d\n",cases++,ans);
		}
		else{
			printf("%d %d\n",cases++,-1);
		}
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值