AtCoder Beginner Contest 113 B - Palace

Problem Statement

A country decides to build a palace.

In this country, the average temperature of a point at an elevation of x meters is Tx×0.006 degrees Celsius.

There are N places proposed for the place. The elevation of Place i is Hi meters.

Among them, Princess Joisino orders you to select the place whose average temperature is the closest to A degrees Celsius, and build the palace there.

Print the index of the place where the palace should be built.

It is guaranteed that the solution is unique.

Constraints

  • 1≤N≤1000
  • 0≤T≤50
  • −60≤AT
  • 0≤Hi≤105
  • All values in input are integers.
  • The solution is unique.

Input

Input is given from Standard Input in the following format:

N
T A
H1 H2 … HN

Output

Print the index of the place where the palace should be built.


Sample Input 1

Copy

2
12 5
1000 2000

Sample Output 1

Copy

1
  • The average temperature of Place 1 is 12−1000×0.006=6 degrees Celsius.
  • The average temperature of Place 2 is 12−2000×0.006=0 degrees Celsius.

Thus, the palace should be built at Place 1.


Sample Input 2

Copy

3
21 -11
81234 94124 52141

Sample Output 2

Copy

3
#include<iostream>
#include<cmath>
using namespace std;

double s[100000];

int main()
{
	int n,m,j,k,i,t,ans,T,a,b;
	cin>>n;
	cin>>a>>b;		
	for (i=0;i<n;i++)
	{
		cin>>s[i];
		s[i]  = a - 0.006*s[i];
	}
	double min = 1000000000.0;
	for (i=0;i<n;i++)
	{
		if (fabs(s[i] - b)<= min)
		{
			min = fabs(s[i]-b);
			ans = i; 
		}
	}
	cout<<ans+1<<endl;
	return 0;
} 

 

转载于:https://www.cnblogs.com/Romantic-Chopin/p/10253054.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值