UVa 11889 - Benefit (数论)

  Benefit 

Recently  Yaghoub  is playing a new trick to sell some more. When somebody gives him  A  Tomans, he who never has appropriate changes, asks for  B  Tomans such that lowest common multiple of  A  and  B  equals to  C  and he will pay back a round bill. Or otherwise take some snack instead of the remaining of his money. He believes that finding such a number is hard enough that dissuades students from paying that.

You should write a program that help poor students giving the appropriate amount of money to Yaghoub. Of course if there are several answers you go for students' benefit which is the lowest of them.

Input 

The first line begin with an integer  T  (   T$ \le$100000 ), the number of tests. Each test that comes in a separate line contains two integers  A and  C  (   1$ \le$AC$ \le$107 ).

Output 

Print the lowest integer  B  such that  LCM(AB) = C  in a single line. If no such integer exists, print " NO SOLUTION " instead. (Quotes for clarity)

Sample Input 

3
2 6
32 1760
7 16

Sample Output 

3
55
NO SOLUTION



题意:

输入两个整数A和C(1<=A,C<= 10^7),求最小的整数B使得LCM(A,B)=C,若无解输出NO SOLUTION


有 A*B = LCM(A,B) * GCD(A,B)

设B' = LCM(A,B) / A 

则B = B' * GCD(A,B)

一种方法是枚举B'的倍数,一直到LCM(A,B)

二是不断把LCM(A,B')吸收到B'中去



#include <cstdio>
#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>
#include <string>
#include <map>
#include <cmath>
#include <queue>
#include <set>

using namespace std;

//#define WIN
#ifdef WIN
typedef __int64 LL;
#define iform "%I64d"
#define oform "%I64d\n"
#define oform1 "%I64d"
#else
typedef long long LL;
#define iform "%lld"
#define oform "%lld\n"
#define oform1 "%lld"
#endif

#define S64I(a) scanf(iform, &(a))
#define P64I(a) printf(oform, (a))
#define P64I1(a) printf(oform1, (a))
#define REP(i, n) for(int (i)=0; (i)<n; (i)++)
#define REP1(i, n) for(int (i)=1; (i)<=(n); (i)++)
#define FOR(i, s, t) for(int (i)=(s); (i)<=(t); (i)++)

const int INF = 0x3f3f3f3f;
const double eps = 10e-9;
const double PI = (4.0*atan(1.0));

LL gcd(LL a, LL b) {
    return b ? gcd(b, a%b) : a;
}

int main() {
    int T;

    scanf("%d", &T);
    while(T--) {
        int a, c;
        scanf("%d%d", &a, &c);
        if(c % a) { puts("NO SOLUTION"); continue; }
        int b = c / a;
        int g = gcd(a, b);
        while(g != 1) {
            b *= g;
            a /= g;
            g = gcd(a, b);
        }
        printf("%d\n", b);
    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值