杭电ACM1062(stack)

杭电ACM1062(stack)

Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output
For each test case, you should output the text which is processed.

Sample Input
3
olleh !dlrow
m’I morf .udh
I ekil .mca

Sample Output
hello world!
I’m from hdu.
I like acm.
题意思路
题目大致让我们翻转给出的单词注意是一个一个的单词,这里我们用STL里面的stack容器也就是栈(先进后出),每次读入一个单词然后输出;

#include<bits/stdc++.h>
using namespace std;
#include<stack>
int main()
{
  char ch;
  int n;
  scanf("%d",&n);
  getchar();
  while(n--){
  	stack<char>s;
   	while(true){
  	ch=getchar();
  	if(ch==' '||ch=='\n'||ch==EOF){
  		while(!s.empty()){
  			printf("%c",s.top());
  			s.pop();
		  }
		  if(ch=='\n'||ch==EOF)
		  break;
		  printf(" ");
	  }
	  else
	  s.push(ch);
  }	
  printf("\n");
}
  	

  return 0;
}
/*
3
olleh !dlrow
m'I morf .udh
I ekil .mca

hello world!
I'm from hdu.
I like acm.
*/;


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

浅蓝色的幸福

感谢你的鼓励

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值