HDU 1062 Text Reverse(简单模拟)

Text Reverse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7548    Accepted Submission(s): 2869

Problem Description

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them. 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output

For each test case, you should output the text which is processed.

Sample Input

3

olleh !dlrow

m'I morf .udh

I ekil .mca 

Sample Output

hello world!

I'm from hdu.

I like acm.

Hint

Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.

Author

Ignatius.L

解题报告:

简单的处理字符串问题,如果遇见字符串问题要合理利用getchar(),在注意处理边界问题

代码如下:
#include <iostream>
#include <cstring>
using namespace std;
char str[1001];
int main()
{
int i, len, n, j;
scanf("%d", &n);
getchar();//度掉回车
while (n --)
{
gets(str);//gets()函数是以回车作为结束标志
len = strlen(str);
for (i = 0; i < len; ++i)
{
if (str[i]== ' ')
{
j = i - 1;
while (str[j] != ' '&&j >=0)
{
printf("%c", str[j]);
j --;
}
printf(" ");
}
else if (i == len - 1)//对最后一个单词的处理
{
j = i;
while (str[j] != ' '&&j >=0)
{
printf("%c", str[j]);
j --;
}
}
}
printf("\n");
}
return 0;
}

 

转载于:https://www.cnblogs.com/lidaojian/archive/2012/02/10/2345511.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值