Text Reverse HDU - 1062题解

这是一道关于逆序输出单词的题目,来自HDU 1062。Ignatius喜欢倒写单词,给定一行文字,你需要将所有单词逆序输出。输入包含多个测试用例,每个用例包含一行单词,最多1000个字符。输出处理后的文字。提示中提醒注意使用getchar()和gets()读取处理。解题思路是利用栈,遇到空格或回车时输出栈内内容。
摘要由CSDN通过智能技术生成

题目

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output

For each test case, you should output the text which is processed.

Sample Input

3
olleh !dlrow
m’I morf .udh
I ekil .mca

Sample Output

hello world!
I’m from hdu.
I like acm.

Hint

Remember to use getchar() to read ‘\n’ after the interger T, then you may use gets() to read a line and process it.

思路

考察栈stack的应用,入栈,到空格或者回车为止输出栈内的内容

代码

#include "bits/stdc++.h"
using namespace std;
int main(){
	int n;
	cin>>n;getchar();//因为要一个一个读入所以要用一个getchar()吃回车;
	while(n--){
		stack<char>ch;
		char temp;
		while(temp=getchar()){
			if(temp==' '){//如果读到了空格,就输出栈里面的内容
				while(!ch.empty()){
					cout<<ch.top();
					ch.pop();
				}
				cout<<" ";
			}
			if(temp=='\n'||temp=='\r'){
				while(!ch.empty()){
					cout<<ch.top();
					ch.pop();
				}
				cout<<endl;
				break;
			}
			ch.push(temp);
			if(temp==' ')ch.pop();
		}
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值