2013成都网络赛 C We Love MOE Girls(水题)

We Love MOE Girls

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 572    Accepted Submission(s): 378


Problem Description
Chikami Nanako is a girl living in many different parallel worlds. In this problem we talk about one of them.
In this world, Nanako has a special habit. When talking with others, she always ends each sentence with "nanodesu".
There are two situations:
If a sentence ends with "desu", she changes "desu" into "nanodesu", e.g. for "iloveyoudesu", she will say "iloveyounanodesu". Otherwise, she just add "nanodesu" to the end of the original sentence.
Given an original sentence, what will it sound like aften spoken by Nanako?
 

 

Input
The first line has a number T (T <= 1000) , indicating the number of test cases.
For each test case, the only line contains a string s, which is the original sentence.
The length of sentence s will not exceed 100, and the sentence contains lowercase letters from a to z only.
 

 

Output
For every case, you should output "Case #t: " at first, without quotes. The  t is the case number starting from 1. Then output which Nanako will say.
 

 

Sample Input
2 ohayougozaimasu daijyoubudesu
 

 

Sample Output
Case #1: ohayougozaimasunanodesu Case #2: daijyoubunanodesu
 

 

Source

 



#include<stdio.h>
#include<string.h>
char a[110];
int main()
{
//freopen("250.txt","r",stdin);
    int t,k=1,i;
    scanf("%d",&t);
    while(k<=t)
    {
        scanf("%s",&a);
        printf("Case #%d: ",k);
        int n=strlen(a);

        if((a[n-4]-'d'==0)&&(a[n-3]-'e'==0)&&(a[n-2]-'s'==0)&&(a[n-1]-'u'==0))
        {

        for(i=0;i<n-4;i++)
        printf("%c",a[i]);
        printf("nanodesu\n");

        }else
        {
            for(i=0;i<n;i++)
            printf("%c",a[i]);
            printf("nanodesu\n");
        }
        k++;
    }
}
View Code

 

转载于:https://www.cnblogs.com/asd1234/p/3394260.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值