Milk Patterns

Milk Patterns
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 19664 Accepted: 8632
Case Time Limit: 2000MS

Description

Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can't predict the quality of milk from one day to the next, there are some regular patterns in the daily milk quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤ N ≤ 20,000) days. He wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ K ≤ N) times. This may include overlapping patterns -- 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least K times.

Input

Line 1: Two space-separated integers:  N and  K 
Lines 2.. N+1:  N integers, one per line, the quality of the milk on day  i appears on the  ith line.

Output

Line 1: One integer, the length of the longest pattern which occurs at least  K times

Sample Input

8 2
1
2
3
2
3
2
3
1

Sample Output

4

Source

 

//#include <bits/stdc++.h>
#include <algorithm>
#include <cstdio>
using namespace std;
typedef long long ll;
typedef pair<int,int> pii;
const int maxn = 1e5 + 10;
int n,k,mx;
int c[maxn],rk[maxn],sa[maxn],tp[maxn],ton[maxn];
int height[maxn];
inline void rsort(){
    for(register int i=0;i<=mx;++i)ton[i]=0;
    for(register int i=1;i<=n;++i)ton[rk[i]]++;
    for(register int i=1;i<=mx;++i)ton[i]=ton[i]+ton[i-1];
    for(register int i=n;i>=1;--i)sa[ton[rk[tp[i]]]--]=tp[i];
}
inline void solve(){
    for(register int i=1;i<=n;++i)rk[i]=c[i],tp[i]=i;
    rsort();
    for(register int w=1,p=0;w<=n&&p<n;w*=2,mx=p){
        p=0;
        for(register int i=n-w+1;i<=n;++i){
            tp[++p]=i;
        }
        for(register int i=1;i<=n;++i){
            if(sa[i]>w){
                tp[++p]=sa[i]-w;
            }
        }
        rsort();
        swap(rk,tp);
        rk[sa[1]]=p=1;
        for(register int i=2;i<=n;++i){
            rk[sa[i]]=(tp[sa[i-1]]==tp[sa[i]]&&tp[sa[i-1]+w]==tp[sa[i]+w])?p:++p;
        }
        if(p>=n)break;
    }
    int k=0;
    for(register int i=1;i<=n;++i)rk[sa[i]]=i;
    for(register int i=1;i<=n;++i){
        if(k)--k;
        else k=0;
        int j=sa[rk[i]-1];
        while(c[i+k]==c[j+k])++k;
        height[rk[i]]=k;
    }
}
inline bool check(int cur){
    int cnt=1;
    for(register int i=2;i<=n;++i){
        if(height[i]<cur)cnt=1;
        else cnt++;
        if(cnt>=k)return true;
    }
    return false;
}
int main() {
    //freopen("1.txt", "r", stdin);
    scanf("%d%d",&n,&k);
    for(register int i=1;i<=n;++i){
        scanf("%d",&c[i]);
        ++c[i];
        mx=max(mx,c[i]);
    }
    //1 2 3 2 3 2 3 1
    solve();
    int res=0;
    int l=1,r=n;
//    for(register int i=1;i<=n;++i){
//        printf("debug rk[%d] = %d sa[%d] = %d height[%d] = %d\n",i,rk[i],i,sa[i],i,height[i]);
//    }
    while(l<=r){
        int mid=l+r>>1;
        if(check(mid))res=mid,l=mid+1;
        else r=mid-1;
    }
    printf("%d\n",res);
    return 0;
}

 

转载于:https://www.cnblogs.com/czy-power/p/11405834.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值