POJ3104 二分

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2

都是套路……套路深啊套路深……
二分最重要的还是判断函数的写法……不看大佬的题解我是推不出需要的式子的……orz
依旧假设所有衣服干的时间为x,只要判断洗衣机的使用时间是不是小于等于x来调整x的值就好了……
洗衣机的使用=(ai-x)/(k-1)之和 (ai>x)

WA了几次……下面贴注意的几点(敲黑板!)
①用int会WA,注意题目数据的范围,用ll
②k=1和0的情况要单独拿出来考虑 ←式子中有k-1,k-2
③向上取整的技巧 a+b-1/b
#include<iostream>
#include<stdio.h>
#include<cmath>
#include<string.h>
#include<algorithm>
typedef long long ll;
using namespace std;
ll n, k;
ll a[1000005];
bool C(ll x)
{
    ll crt=0;
    for (int i = 0; i <n; i++)
    {
        if (a[i] > x)
        {
            crt += (a[i] - x + (k - 2)) / (k - 1);
            if (crt > x) return true;
        }
    }
    return false;
}
int main()
{
    while (scanf("%lld", &n) != EOF)
    {
        for (int i = 0; i < n; i++)
            scanf("%lld", &a[i]);
        scanf("%lld", &k);
        sort(a, a + n);
        if (k == 0 || k == 1)
            printf("%d\n", a[n - 1]);
        else {
            ll l = 0, h = 0x3f3f3f3f;
            while (h - l > 1)
            {
                ll mid = (l + h) / 2;
                if (C(mid)) l = mid;
                else h = mid;
            }
            printf("%lld\n", h);
        }
    }
    return 0;
}
 
 

 

转载于:https://www.cnblogs.com/Egoist-/p/7405323.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值