poj--1703--Find them, Catch them(并查集巧用)

Time Limit: 1000MS Memory Limit: 10000KB 64bit IO Format: %I64d & %I64u

Status

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source

POJ Monthly--2004.07.18

输出少了一个“.”wa了四次-.-||
题意:有两个帮派,现在给了n个人m个关系,D:关系表示两个人不在一个帮派,A:查询两个人是否在一个帮派,不确定的话输出“Not sure yet.“,同一个输出”In the same gang.“,不在一个输出”In different gangs.“。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int pre[100010],rank[100010];
int find(int x)
{
	if(pre[x]==x)
	return x;
	else
	{
		int temp=pre[x];
		pre[x]=find(pre[x]);
		rank[x]=(rank[x]+rank[temp])%2;//将x变为和temp一样的帮派 
		return pre[x];
	}
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		memset(rank,0,sizeof(rank));//rank表示层数,两层表示不一样的帮派 
		char op[2];
		int x,y;
		int m,n;
		scanf("%d%d",&n,&m);
		for(int i=1;i<=n;i++)
		pre[i]=i;
		for(int i=0;i<m;i++)
		{
			scanf("%s%d%d",op,&x,&y);
			int fx=find(x);
			int fy=find(y);
			if(op[0]=='D')
			{
				pre[fy]=fx;
				rank[fy]=(rank[x]-rank[y]+1)%2;
				continue;
			}
			else
			{
				if(fx!=fy)//根节点不一样应该就是尚未分配,所以不确定 
				printf("Not sure yet.\n");
				else if(rank[x]!=rank[y])//层数不一样就不在一个帮派 
				printf("In different gangs.\n");
				else if(rank[x]==rank[y])//层数一样并且根节点相同 
				printf("In the same gang.\n");
			}	
		}
	}
	return 0;
}


转载于:https://www.cnblogs.com/playboy307/p/5273682.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值