POJ-1703 Find them,Catch them(并查集)

传送门

POJ-1703 Find them, Catch them

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

  1. D [a] [b]
    where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

  2. A [a] [b]
    where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message “A [a] [b]” in each case, your program should give the judgment based on the information got before. The answers might be one of “In the same gang.”, “In different gangs.” and “Not sure yet.”

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

思路

这道题就是敌人的敌人是朋友,我们开辟2*n个空间利用并查集维护他们的关系,我们模拟元素i的敌人是i+n:
当D x y时,unite(x,y+n),unite(x+n,y):这样x和y就成了对立的关系,而且x和y+n、y和x+n属于一个集合,这就使得x和y的敌人(y+n)成为了朋友,y和x的敌人(x+n)成为了朋友,让我们看看接下来发生什么;
当D y z时,unite(y,z+n),unite(y+n,z):这样y和z就成了对立的关系,而且y和z+n、z和y+n属于一个集合。这时,x、y+n和z成了朋友而x+n、y和z+n成为了朋友,我们成功模拟出元素间的关系:
x和z是朋友,x的敌人x+n、z的敌人z+n和y是朋友,所以(x、z)和y互为敌人;
关于处理x和无关系间元素q:如果x和q既不是敌人也不是朋友,那么就输出Not sure yet.

解决代码

#include<iostream>
using namespace std;
const int maxx=2*(1e5+5);
struct Edge
{
	int par,h;
};
Edge e[maxx];
void init(int n)
{
	for (int i = 1; i <= n; i++)
	{
		e[i].par=i;
		e[i].h=0;
	}
}
int find(int x)
{
	return x==e[x].par? x :e[x].par=find(e[x].par);
}
void unite(int x,int y)
{
	x=find(x);
	y=find(y);
	if (x==y) return ;
	if (e[x].h<e[y].h)
	{
		e[x].par=y;
	}
	else
	{
		e[y].par=x;
		if(e[x].h==e[y].h) e[x].h++;
	}
}
bool same(int x,int y)
{
	return find(x)==find(y);
}
int main()
{
	int q;
	scanf("%d",&q);
	while (q--)
	{
		int n,m;
		scanf("%d%d",&n,&m);
		init(2*n);
		for (int i = 0; i < m; i++)
		{
			char x;
			int y,z;
			scanf(" %c%d%d",&x,&y,&z);//空格用来吸收缓冲区中的回车
			if(x=='D')
			{
				unite(y,z+n);
				unite(y+n,z);
			}
			else
			{
				if (same(y,z))
				{
					printf("In the same gang.\n");
				}
				else if(same(y+n,z))
				{
					printf("In different gangs.\n");
				}
				else 
				{
					printf("Not sure yet.\n");
				}
			}
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

新西兰做的饭

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值