hdu 1018 Big Number (斯特林公式)


(先看题目)

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 36652    Accepted Submission(s): 17576


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
 
  
2 10 20
 

Sample Output
 
  
7 19
 
//题意 就是给定一个数 让你求这个数的阶乘的 位数,    首先普通的方法一定会溢出, ,  百度了一下  有一个公式 正好可以求阶乘的 位数,  即 斯特林公式

斯特林公式就可以用于求这个阶乘的位数,

斯特林公式(Stirling'sapproximation)是一条用来取n的阶乘的近似值的数学公式。一般来说,当n很大的时候,

n阶乘的计算量十分大,所以斯特林公式十分好用,而且,即使在n很小的时候,斯特林公式的取值已经十分准确。

上式两边同时取log10,得到的是log10(n!) =log10(2*pi*n)/2+n*log10(n/e)

所以其位数应该可以表示为:

log10(2*pi*n)/2+n*log10(n/e)+1

 

//  这里要注意一下 在math.h中 log()   e为底  log10x 10为底



#include<stdio.h>
#include<math.h>


#define PI 3.14159265




int main()
{
	double n;
	int T;
	while(~scanf("%d",&T))
	{
		while(T--)
		{
			scanf("%lf",&n);
			n=(n*log(n)-n + 0.5*log(2*PI*n))/log(10);将公式 同时转化 成以e为底的 log函数 
//			printf("%lf\n",n);
			n=((int)n+1);
			printf("%.lf\n",n); 
		}
	}
	return 0;
}


转载于:https://www.cnblogs.com/sizaif/p/9078603.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值