11479 - Is this the easiest problem?

A triangle is a geometric shape with three positive sides. However, any given three sides won’t necessarily form a triangle. The three sides must form a closed region. Triangles are categorized depending on the values of the sides of a valid triangle. In this problem you are required to determine the type of a triangle.

 

 
 Input  
 

The first line of input will contain a positive integer T<20, where T denotes the number of test cases. Each of the next T lines will contain three 32 bit signed integer.

 
   
 Output 
 

For each case of  input there will be one line of output. It will be formatted as:
Case {x}: {triangle type}. Where x denotes the case number being processed and {triangle type} is the type of the triangle..{triangle type} will be one of the following, depending on the values of the three sides:

  • Invalid - The three sides can not form a triangle
  • Equilateral  - All three sides of valid triangle are equal
  • Isosceles  - Exactly two of the sides of a valid triangle are equal.
  • Scalene - No pair of sides are equal in a valid triangle.
 
   
 Sample InputSample Output   
 

4
1 2 5
1 1 1
4 4 2
3 4 5

Case 1: Invalid
Case 2: Equilateral
Case 3: Isosceles
Case 4: Scalene

 解题思路:判断三角形类型,定义使用long long,注意各类三角形的条件

#include<stdio.h>
int main()
{long long n,i,a,b,c;
scanf("%lld",&n);
for(i=1;i<=n;i++){
                  scanf("%lld%lld%lld",&a,&b,&c);
                  if(!(a + b > c && a + c > b && c + b > a) || a <= 0 || b <= 0 || c <= 0)
                  printf("Case %d: Invalid\n", i);
                  else if(a == b && c == b && c == a)
                  printf("Case %d: Equilateral\n", i);
                  else if(a == b || c == b || c == a)
                  printf("Case %d: Isosceles\n", i);
                  else if(a != b && c != b && c != a)
                  printf("Case %d: Scalene\n", i);                
                  }
return 0;
}

 

转载于:https://www.cnblogs.com/EVA00/archive/2013/02/08/2909208.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip 【备注】 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用!有问题请及时沟通交流。 2、适用人群:计算机相关专业(如计科、信息安全、数据科学与大数据技术、人工智能、通信、物联网、自动化、电子信息等)在校学生、专业老师或者企业员工下载使用。 3、用途:项目具有较高的学习借鉴价值,不仅适用于小白学习入门进阶。也可作为毕设项目、课程设计、大作业、初期项目立项演示等。 4、如果基础还行,或热爱钻研,亦可在此项目代码基础上进行修改添加,实现其他不同功能。 欢迎下载!欢迎交流学习!不清楚的可以私信问我! 毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip毕设新项目-基于Java开发的智慧养老院信息管理系统源码+数据库(含vue前端源码).zip
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值