Contiguous Repainting

题目描述

There are N squares aligned in a row. The i-th square from the left contains an integer ai.

Initially, all the squares are white. Snuke will perform the following operation some number of times:

Select K consecutive squares. Then, paint all of them white, or paint all of them black. Here, the colors of the squares are overwritten.
After Snuke finishes performing the operation, the score will be calculated as the sum of the integers contained in the black squares. Find the maximum possible score.

Constraints
1≤N≤10 5
1≤K≤N
ai is an integer.
|ai|≤10 9

输入

The input is given from Standard Input in the following format:

N K
a 1 a 2 … a N

输出

Print the maximum possible score.

样例输入

5 3
-10 10 -10 10 -10

样例输出

10

提示

Paint the following squares black: the second, third and fourth squares from the left.Contiguous Repainting

除了最后一次刷,再这一k段序列的其他正数都可以取到

把这k段序列当作刷白的中转站,反正就算黑了几个再把这k个刷白。

最后再考虑这k个要不要刷黑

#include <bits/stdc++.h>
#define ll long long
using namespace std;
const int maxn=1e5+5;
ll s[maxn],a[maxn];
int main(){
    int n,k,t;
    cin>>n>>k;
    for(int i=1;i<=n;i++){
        cin>>t;
        s[i]=s[i-1]+t;
        a[i]=a[i-1];
        if(t>0) a[i]+=t;
    }
    ll ans=0;
    for(int i=1;i+k-1<=n;i++){
        ll sum=a[n]-(a[i+k-1]-a[i-1]);
        if(s[i+k-1]-s[i-1]>0) sum+=s[i+k-1]-s[i-1];
        ans=max(ans,sum);
    }
    cout<<ans<<endl;
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/smallocean/p/8886765.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值