HDU - 4587 TWO NODES (图的割点)

Suppose that G is an undirected graph, and the value of  stab is defined as follows: 

Among the expression,G  -i, -j is the remainder after removing node i, node j and all edges that are directly relevant to the previous two nodes.  cntCompent is the number of connected components of X independently. 
Thus, given a certain undirected graph G, you are supposed to calculating the value of  stab.

InputThe input will contain the description of several graphs. For each graph, the description consist of an integer N for the number of nodes, an integer M for the number of edges, and M pairs of integers for edges (3<=N,M<=5000). 
Please note that the endpoints of edge is marked in the range of [0,N-1], and input cases ends with EOF.OutputFor each graph in the input, you should output the value of stab.Sample Input

4 5
0 1
1 2
2 3
3 0
0 2

Sample Output

2

题意:
问删除两个点后最大的联通块个数
思路:
没想到是一个暴力题,看了一下数据范围才反应过来.
题目既然要删除两个点,那就先枚举删除第一个点,再用割点判断第二个点删除后的联通块个数即可.
当然,有几点要注意一下:
1.联通块中点的个数全为1:
数据: 8 0
2.联通块中没有割点
 数据:
  3 3
  0 1
  0 2
  1 3

#include<iostream>
#include<algorithm>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<ctime>

#define fuck(x) cerr<<#x<<" = "<<x<<endl;
#define debug(a, x) cerr<<#a<<"["<<x<<"] = "<<a[x]<<endl;
#define ls (t<<1)
#define rs ((t<<1)|1)
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int maxn = 100086;
const int maxm = 100086;
const int inf = 0x3f3f3f3f;
const ll Inf = 999999999999999999;
const int mod = 1000000007;
const double eps = 1e-6;
const double pi = acos(-1);

int Head[maxn], cnt;
struct edge {
    int Next, v;
} e[maxm];

void add_edge(int u, int v) {
    e[cnt].Next = Head[u];
    e[cnt].v = v;
    Head[u] = cnt++;
}

int Index = 0;
int dfn[maxn], low[maxn], root;
int vis[maxn];

int exc;
int ans;
int flag;
void dfs(int cur, int father) {
    if(cur==exc){ return;}
    flag++;
    int child = 0;
    Index++;
    dfn[cur] = Index;
    low[cur] = Index;
    for (int k = Head[cur]; k != -1; k = e[k].Next) {
        if(e[k].v==exc){ continue;}
        if (dfn[e[k].v] == 0) {
            child++;
            dfs(e[k].v, cur);
            low[cur] = min(low[cur], low[e[k].v]);
            if (cur != root && low[e[k].v] >= dfn[cur]) {
                vis[cur]++;
            }
            if (cur == root && child >= 2) {
                vis[cur]++;
            }
        } else if (e[k].v != father) {
            low[cur] = min(low[cur], dfn[e[k].v]);
        }
    }
}


int main() {
//    ios::sync_with_stdio(false);
//    freopen("in.txt", "r", stdin);

    int n,m;
    while (scanf("%d%d",&n,&m)!=EOF) {
        memset(Head, -1, sizeof(Head));
        cnt=0;
        for (int i = 1; i <= m; i++) {
            int x, y;
            scanf("%d%d", &x, &y);
            add_edge(x + 1, y + 1);
            add_edge(y + 1, x + 1);
        }

        int mx = 0;
        for (int i = 1; i <= n; i++) {
            exc = i;
            ans = 0;
            memset(vis, 0, sizeof(vis));
            memset(dfn, 0, sizeof(dfn));
            Index=0;
            dfn[exc]=-1;
            int tmp = -1;
            for (int j = 1; j <= n; j++) {
                if (!dfn[j] && j != i) {
                    root = j;
                    flag=0;
                    dfs(j, j);
                    if(flag>1){
                        tmp=0;//如果联通块内只有一个点,那么删除这个点之后,会使联通块少一
                        //所以至少保证有一个联通块内部包含了两个点,否则答案要减一
                    }
                    ans++;//已有的联通块
                }
            }

            for (int j = 1; j <= n; j++) {
                if(vis[j])tmp=max(tmp,vis[j]);//删去割点之后,可以获得的联通块
            }
            mx = max(ans+tmp, mx);
        }
        printf("%d\n", mx );
    }
    return 0;
}
View Code

转载于:https://www.cnblogs.com/ZGQblogs/p/11194806.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
目标检测(Object Detection)是计算机视觉领域的一个核心问题,其主要任务是找出像中所有感兴趣的目标(物体),并确定它们的类别和位置。以下是对目标检测的详细阐述: 一、基本概念 目标检测的任务是解决“在哪里?是什么?”的问题,即定位出像中目标的位置并识别出目标的类别。由于各类物体具有不同的外观、形状和姿态,加上成像时光照、遮挡等因素的干扰,目标检测一直是计算机视觉领域最具挑战性的任务之一。 二、核心问题 目标检测涉及以下几个核心问题: 分类问题:判断像中的目标属于哪个类别。 定位问题:确定目标在像中的具体位置。 大小问题:目标可能具有不同的大小。 形状问题:目标可能具有不同的形状。 三、算法分类 基于深度学习的目标检测算法主要分为两大类: Two-stage算法:先进行区域生成(Region Proposal),生成有可能包含待检物体的预选框(Region Proposal),再通过卷积神经网络进行样本分类。常见的Two-stage算法包括R-CNN、Fast R-CNN、Faster R-CNN等。 One-stage算法:不用生成区域提议,直接在网络中提取特征来预测物体分类和位置。常见的One-stage算法包括YOLO系列(YOLOv1、YOLOv2、YOLOv3、YOLOv4、YOLOv5等)、SSD和RetinaNet等。 四、算法原理 以YOLO系列为例,YOLO将目标检测视为回归问题,将输入像一次性划分为多个区域,直接在输出层预测边界框和类别概率。YOLO采用卷积网络来提取特征,使用全连接层来得到预测值。其网络结构通常包含多个卷积层和全连接层,通过卷积层提取像特征,通过全连接层输出预测结果。 五、应用领域 目标检测技术已经广泛应用于各个领域,为人们的生活带来了极大的便利。以下是一些主要的应用领域: 安全监控:在商场、银行
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值