hdu4587TWO NODES【割点】

Description

Suppose that G is an undirected graph, and the value of stab is defined as follows:

Among the expression,G -i, -j is the remainder after removing node i, node j and all edges that are directly relevant to the previous two nodes. cntCompent is the number of connected components of X independently.
Thus, given a certain undirected graph G, you are supposed to calculating the value of stab.
 

Input

The input will contain the description of several graphs. For each graph, the description consist of an integer N for the number of nodes, an integer M for the number of edges, and M pairs of integers for edges (3<=N,M<=5000).
Please note that the endpoints of edge is marked in the range of [0,N-1], and input cases ends with EOF.
 

Output

For each graph in the input, you should output the value of stab.
 

Sample Input

    
    
4 5 0 1 1 2 2 3 3 0 0 2
 

Sample Output

  
  
2
题意:已知无向图选两个点点从原图中删掉,剩下的最大连通分量个数?

做法:很容易想到应该从个点入手,然而就算枚举割点,要怎么算呢?(下午试试这种枚举所有割点的方法)

本题的解法是第一个点枚举所有点,第二个点由dfs求出最大值。具体来说就是iscut原来表示是否是割点,现在让他作为“遍历时成为割点的次数”即为子树的个数。

那么对于非根节点,删去后剩余个数为iscut[i] + 1(子树个数加上父节点),根节点为iscut[i] (没有父节点)

那么全题答案便是 max(iscut[i] + 1) + left - 1

#pragma comment(linker, "/STACK:102400000000,102400000000")
#include <iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
#define maxn 5009
vector<int>G[maxn];
int pre[maxn],dfs_cnt,iscut[maxn];
int n,m,none;
void init()
{
    for(int i=0;i<n;i++)G[i].clear();
    none=n;
}
int dfs(int u,int fa)
{
    int lowu=pre[u]=++dfs_cnt;
    int child=0;
    for(int i=0;i<G[u].size();i++)
    {
        int v=G[u][i];
        if(v==none) continue;
        if(!pre[v])
        {
            child++;
            int lowv=dfs(v,u);
            lowu=min(lowu,lowv);
            if(lowv>=pre[u])
                iscut[u]++;
        }
        else if(pre[v]<pre[u]&&v!=fa)
            lowu=min(lowu,pre[v]);
    }
    if(fa<0&&child==1)iscut[u]=0;
    return lowu;
}
int solve(int x)
{
    int ans=0,left=0;
    memset(iscut,0,sizeof(iscut));
    dfs_cnt=0;
    memset(pre,0,sizeof(pre));
    none=x;
    for(int i=0;i<n;i++)
        if(i!=x&&!pre[i])
            iscut[i]--,left++,dfs(i,-1);
    for(int i=0;i<n;i++)
        if(i!=x)
        ans=max(ans,iscut[i]+1);
    ans+=left-1;
    return ans;
}
int main()
{
  //  freopen("cin.txt","r",stdin);
    while(~scanf("%d%d",&n,&m))
    {
        init();
        while(m--)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            G[u].push_back(v);
            G[v].push_back(u);
        }
        int ans=0;
        for(int i=0;i<n;i++)
            ans=max(ans,solve(i));
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值