poj 1840 Eqs 【解五元方程+分治+枚举打表+二分查找所有key 】

Eqs
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 13955 Accepted: 6851

Description

Consider equations having the following form:
a1x1 3+ a2x2 3+ a3x3 3+ a4x4 3+ a5x5 3=0
The coefficients are given integers from the interval [-50,50].
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}.

Determine how many solutions satisfy the given equation.

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654
分析:将等式方程左边3、4项移到等号右边,是方程变成一个另外一种等式。
枚举左边打表,枚举右边查表。 或者 枚举右边打表,枚举左边查表。
复杂度:n^3+n^2(logn) 或者 n^2+n^3(logn) 复杂度两者差不多。
代码1:
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <ctype.h>
#include <math.h>
#include <cmath>
#include <iostream>
#include <string>
#include <queue>
#include <stack>
#include <vector>
#include <algorithm>
#define N 100000+100

using namespace std;

int f[1000100];

//复杂度=三层枚举打表+两层枚举*二分
//(记得数组要在二层打表的基础上扩大一下 否则访问越界)

int B_search(int low, int high, int key)
{
    int mid;
    while(low<=high)
    {
        mid=(low+high)/2;
        if(f[mid]==key ){
            int u=mid-1, v=mid+1;
            while(f[u]==key) u--;
            while(f[v]==key) v++;
            return v-u-1;
        }
        else if(f[mid]>key){
            high=mid-1;
        }
        else low=mid+1;
    }
    return 0;
}

int main()
{
    int a, b, c, d, e;
    int i, j, k;
    while(scanf("%d %d %d %d %d", &a, &b, &c, &d, &e)!=EOF)
    {
    int cnt=0;
        for(i=-50; i<=50; i++){
            if(i!=0)
            for(j=-50; j<=50; j++){
                if(j!=0)
                for(k=-50; k<=50; k++){
                    if(k!=0){
                        int cur=-c*i*i*i-d*j*j*j-e*k*k*k;
                        f[cnt++]=cur;
                    }
                }
            }
        }

    sort(f, f+cnt);

    int ans=0;
    for(i=-50; i<=50; i++){
        if(i!=0){
        for(j=-50; j<=50; j++){
            if(j!=0){
                int cur=a*i*i*i + b*j*j*j;
                ans=ans+B_search(0, cnt-1, cur);
            }
        }
        }
    }
    printf("%d\n", ans );
    }
    return 0;
}

 代码2:

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <ctype.h>
#include <math.h>
#include <cmath>
#include <iostream>
#include <string>
#include <queue>
#include <stack>
#include <vector>
#include <algorithm>
#define N 100000+100

using namespace std;

int f[20000];

//复杂度=两层枚举打表+三层枚举*二分
int B_search(int low, int high, int key)
{
    int mid;
    while(low<=high)
    {
        mid=(low+high)/2;
        if(f[mid]==key ){
            int u=mid-1, v=mid+1;
            while(f[u]==key) u--;
            while(f[v]==key) v++;
            return v-u-1;
        }
        else if(f[mid]>key){
            high=mid-1;
        }
        else low=mid+1;
    }
    return 0;
}

int main()
{
    int a, b, c, d, e;
    int i, j, k;
    while(scanf("%d %d %d %d %d", &a, &b, &c, &d, &e)!=EOF)
        {
    queue<int>q; while(!q.empty()) q.pop();

    //-d*i*i*i-e*j*j*j 全部入队列
    int cnt=0;

    for(i=-50; i<=50; i++){
        if(i!=0)
        for(j=-50; j<=50; j++){
            if(j!=0){
            int cur=-d*i*i*i-e*j*j*j;
            f[cnt++]=cur; }
        }
    }
    sort(f, f+cnt);
    //printf("************\n");

    int ans=0;

    for(i=-50; i<=50; i++){
        if(i!=0)
        for(j=-50; j<=50; j++){
            if(j!=0)
            for(k=-50; k<=50; k++){
                if(k!=0){
                int cur=a*i*i*i + b*j*j*j + c*k*k*k;
                    ans=ans+B_search(0, cnt-1, cur);
                }
            }
        }
    }
    printf("%d\n", ans );
    }
    return 0;
}

 

 

转载于:https://www.cnblogs.com/yspworld/p/4694151.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值