Codeforces Round #345 (Div. 2)C. Watchmen(想法题)

传送门

Description

Watchmen are in a danger and Doctor Manhattan together with his friend Daniel Dreiberg should warn them as soon as possible. There are n watchmen on a plane, the i-th watchman is located at point (xi, yi).

They need to arrange a plan, but there are some difficulties on their way. As you know, Doctor Manhattan considers the distance between watchmen i and j to be |xi - xj| + |yi - yj|. Daniel, as an ordinary person, calculates the distance using the formula .

The success of the operation relies on the number of pairs (i, j) (1 ≤ i < j ≤ n), such that the distance between watchman i and watchmen j calculated by Doctor Manhattan is equal to the distance between them calculated by Daniel. You were asked to compute the number of such pairs.

Input

The first line of the input contains the single integer n (1 ≤ n ≤ 200 000) — the number of watchmen.

Each of the following n lines contains two integers xi and yi (|xi|, |yi| ≤ 109).

Some positions may coincide.

Output

Print the number of pairs of watchmen such that the distance between them calculated by Doctor Manhattan is equal to the distance calculated by Daniel.

Sample Input

 
  
6
0 0
0 1
0 2
-1 1
0 1
1 1

3
1 1
7 5
1 5
 

Sample Output

11

2

Note

In the first sample, the distance between watchman 1 and watchman 2 is equal to |1 - 7| + |1 - 5| = 10 for Doctor Manhattan and  for Daniel. For pairs (1, 1), (1, 5) and (7, 5), (1, 5) Doctor Manhattan and Daniel will calculate the same distances.

思路

题解:

将两个距离公式平方,可以发现,只要点x与点y中其坐标x或是坐标y的值有一个相同,则这两个点用这两个公式算出来的值就是相同的。

 

#include<bits/stdc++.h>
using namespace std;
int  main()
{
    map<int, int>x;
    map<int, int>y;
    map<pair<int,int>, int>cross;
    int n;
    long long res = 0;
    scanf("%d", &n);
    while(n--)
    {
        int xx, yy;
        scanf("%d%d", &xx, &yy);
        res += x[xx]++;
        res += y[yy]++;
        res -= cross[make_pair(xx,yy)]++;
    }
    cout << res << endl;
    return 0;
}

  

#include<bits/stdc++.h>
using namespace std;

struct Node{
	int x,y;
	bool operator < (const Node &a) const  
    {  
        if (x == a.x)	return y < a.y;
		else	return x < a.x;  
    }  
}; 

int  main()
{
    map<int, int>x;
    map<int, int>y;
    map<Node, int>cross;
    int n;
    long long res = 0;
    scanf("%d", &n);
    while(n--)
    {
        int xx, yy;
        scanf("%d%d", &xx, &yy);
        res += x[xx]++;
        res += y[yy]++;
        res -= cross[(Node){xx,yy}]++;
    }
    cout << res << endl;
    return 0;
}

  

转载于:https://www.cnblogs.com/ZhaoxiCheung/p/6790797.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值