SDUTOJ3344数据结构实验之二叉树五:层序遍历

数据结构实验之二叉树五:层序遍历

https://acm.sdut.edu.cn/onlinejudge2/index.php/Home/Contest/contestproblem/cid/2711/pid/3344

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。

Input

 输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是一个长度小于50个字符的字符串。

Output

 输出二叉树的层次遍历序列。

Sample Input

2
abd,,eg,,,cf,,,
xnl,,i,,u,,

Sample Output

abcdefg
xnuli

Hint

 

Source

xam

 

 

#include <bits/stdc++.h>
using namespace std;
struct tree
{
    char c;
    tree *l, *r;
};
int cnt;
char s[100];
tree *creat(tree *root) // 构建二叉树
{
    if (s[cnt] == ',')
    {
        cnt++;
        return NULL;
    }
    root = new tree;
    root->c = s[cnt++];
    root->l = creat(root->l);
    root->r = creat(root->r);
    return root;
}
void show(tree *root) // 层序遍历二叉树 // 通过队列实现
{
    queue<tree *> q;
    if (root)
        q.push(root);
    while (!q.empty())
    {
        root = q.front();
        q.pop();
        if (root)
        {
            cout << root->c;
            q.push(root->l);
            q.push(root->r);
        }
    }
}
int main()
{
    int n;
    // char s[100];
    cin >> n;
    while (n--)
    {
        tree *tree;
        cin >> s;
        cnt = 0;
        tree = creat(tree);
        show(tree);
        cout << endl;
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/iQXQZX/p/10258798.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值