freckles

题目描述:

    In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad's back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley's engagement falls through. 
    Consider Dick's back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.

输入:

    The first line contains 0 < n <= 100, the number of freckles on Dick's back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.

输出:

    Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.

样例输入:
3
1.0 1.0
2.0 2.0
2.0 4.0
样例输出:
3.41

这道题就是输入n,和n个坐标

然后输出将所有点连起来的最短路径

还是最小生成树

#include<iostream>
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
int path[101];

struct edge{
    int a,b;
    double cost;
    bool operator <(const edge &A) const{
        return cost<A.cost;
    }
}edge[5000];


int findroot(int a){
    int temp=a;
    while (path[a] != -1){
        a=path[a];
    }
    int temp2;

    while (path[temp]!= -1){
        temp2=path[temp];
        path[temp]=a;
        temp=temp2;
    }
    return a;
}

int main (){
    int n;
    double point[101][2];
    while (cin>>n){
        int size=1;
        for (int i=1;i<=n;i++){
            cin>>point[i][0]>>point[i][1];
            for (int j=1;j<i;j++){
                edge[size].a=i;
                edge[size].b=j;
                edge[size].cost=sqrt(pow(point[i][0]-point[j][0],2.0)+pow(point[i][1]-point[j][1],2.0));
                size++;
            }
        }
        
        int nn=n*(n-1)/2;
        for (int i=1;i<=n;i++){
            path[i]=-1; 
        }
        double ans=0;

        sort(edge+1,edge+1+nn);
        int a,b;
        for (int i=1;i<=nn;i++){
            a=edge[i].a;
            b=edge[i].b;
            a=findroot(a);
            b=findroot(b);
            if (a!=b){
                path[a]=b;
                ans += edge[i].cost;
            } 
        }

        printf("%.2lf\n",ans);//输出精确到两位小数 
    } 
    return 0;

}
//图论的edge什么的下标都是从1开始的,而不是0比较方便 

学会了输出两位小数怎么做

 

转载于:https://www.cnblogs.com/yexiaoqi/p/7234252.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值