题目1144:Freckles

题目描述:

    In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad's back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley's engagement falls through. 
    Consider Dick's back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle. 

输入:

    The first line contains 0 < n <= 100, the number of freckles on Dick's back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.

输出:

    Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.

样例输入:
3
1.0 1.0
2.0 2.0
2.0 4.0
样例输出:
3.41

代码:

#include <stdio.h>
#include <math.h>
#include <algorithm>
using namespace std;

int tree[100];
int findRoot(int x) {
    if(tree[x] == -1) return x;
    else {
	int tmp = findRoot(tree[x]);
	tree[x] = tmp;
	return tmp;
    }
}

struct Edge {
    int a;
    int b;
    double d;
}edge[5000];

struct Point {
    double x;
    double y;
    double getDist(Point A) {
	double tmp = (x - A.x) * (x - A.x) + (y - A.y) * (y - A.y);
	return sqrt(tmp);
    }
}point[100];

bool cmp(Edge A, Edge B) {
    return A.d < B.d;
}

int main() {
    int n;
    while(scanf("%d",&n)!=EOF) {
	for(int i=1;i<=n;i++)
	    scanf("%lf %lf",&point[i].x,&point[i].y);
	int size = 0;
	for(int i=1;i<=n;i++) //把所有点都连接起来构成许多边
	    for(int j=i+1;j<=n;j++) {
		edge[size].a = i;
		edge[size].b = j;
		edge[size].d = point[i].getDist(point[j]);
		size++;
	    }
	sort(edge,edge+size,cmp);
	for(int i=1;i<=n;i++)
	    tree[i] = -1;
	double sum = 0;
	for(int i=0;i<size;i++) {
	    int x = findRoot(edge[i].a);
	    int y = findRoot(edge[i].b);
	    if(x!=y) {
		tree[x] = y;
		sum += edge[i].d;
	    }
	}
	printf("%.2lf\n",sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值