HDU 2164 Rock, Paper, or Scissors?

http://acm.hdu.edu.cn/showproblem.php?pid=2164

 

Problem Description
Rock, Paper, Scissors is a two player game, where each player simultaneously chooses one of the three items after counting to three. The game typically lasts a pre-determined number of rounds. The player who wins the most rounds wins the game. Given the number of rounds the players will compete, it is your job to determine which player wins after those rounds have been played. 

The rules for what item wins are as follows:

?Rock always beats Scissors (Rock crushes Scissors)
?Scissors always beat Paper (Scissors cut Paper)
?Paper always beats Rock (Paper covers Rock) 
 
Input
The first value in the input file will be an integer t (0 < t < 1000) representing the number of test cases in the input file. Following this, on a case by case basis, will be an integer n (0 < n < 100) specifying the number of rounds of Rock, Paper, Scissors played. Next will be n lines, each with either a capital R, P, or S, followed by a space, followed by a capital R, P, or S, followed by a newline. The first letter is Player 1抯 choice; the second letter is Player 2抯 choice.

 
Output
For each test case, report the name of the player (Player 1 or Player 2) that wins the game, followed by a newline. If the game ends up in a tie, print TIE.
 
Sample Input
3
2
R P
S R
3
P P
R S
S R
1
P R
 
Sample Output
Player 2
TIE
Player 1
 
代码:
#include <bits/stdc++.h>
using namespace std;

char p1[1111], p2[1111];

int cmp(char a, char b) {

    if(a == 'S') {
        if(b == 'P') return 2;
        if(b == 'R') return 1;
    }

    if(a == 'R') {
        if(b == 'S') return 2;
        if(b == 'P') return 1;
    }

    if(a == 'P') {
        if(b == 'R') return 2;
        if(b == 'S') return 1;
    }
}

int main() {
    int T;
    scanf("%d", &T);
    while(T --) {
        int x;
        scanf("%d", &x);
        int cnt = 0, ans = 0;
        getchar();
        for(int i = 1; i <= x; i ++) {
            scanf("%c %c", &p1[i], &p2[i]);
            getchar();
            if(cmp(p1[i], p2[i]) == 2)
                cnt ++;
            else if(cmp(p1[i], p2[i]) == 1)
                ans ++;
        }

        if(cnt > ans)
            printf("Player 1\n");
        else if(cnt == ans)
            printf("TIE\n");
        else
            printf("Player 2\n");
    }
    return 0;
}

  

 

 

转载于:https://www.cnblogs.com/zlrrrr/p/9417374.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值