Coloring Dominoes

问题 E: Coloring Dominoes

时间限制: 1 Sec   内存限制: 128 MB
提交: 279   解决: 95
[ 提交] [ 状态] [ 讨论版] [命题人: ]
题目描述
We have a board with a 2×N grid. Snuke covered the board with N dominoes without overlaps. Here, a domino can cover a 1×2 or 2×1 square.
Then, Snuke decided to paint these dominoes using three colors: red, cyan and green. Two dominoes that are adjacent by side should be painted by different colors. Here, it is not always necessary to use all three colors.
Find the number of such ways to paint the dominoes, modulo 1000000007.
The arrangement of the dominoes is given to you as two strings S1 and S2 in the following manner:
Each domino is represented by a different English letter (lowercase or uppercase).
The j-th character in Si represents the domino that occupies the square at the i-th row from the top and j-th column from the left.

Constraints
1≤N≤52
|S1|=|S2|=N
S1 and S2 consist of lowercase and uppercase English letters.
S1 and S2 represent a valid arrangement of dominoes.

输入
Input is given from Standard Input in the following format:
N
S1
S2

输出
Print the number of such ways to paint the dominoes, modulo 1000000007.


样例输入
3
aab
ccb

样例输出
6

提示

There are six ways as shown below:


分析:这题。。找规律。。

#include <iostream>
#include <string>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
#include <deque>
#include <map>
#define range(i,a,b) for(auto i=a;i<=b;++i)
#define LL long long
#define itrange(i,a,b) for(auto i=a;i!=b;++i)
#define rerange(i,a,b) for(auto i=a;i>=b;--i)
#define fill(arr,tmp) memset(arr,tmp,sizeof(arr))
using namespace std;
const int dev=1000000007;
int n;
string s1,s2;
bool flag;
LL ans;
void init(){
    cin>>n>>s1>>s2;
    ans=s1[0]==s2[0]?3:6;
    flag=s1[0]!=s2[0];
}
void solve(){
    range(i,flag?2:1,n-1){
        if(s1[i]==s2[i]){
            if(!flag)ans=(ans<<1)%dev;
            flag=false;
        }
        else{
            if(flag)ans=ans*3%dev;
            else ans=(ans<<1)%dev;
            ++i;flag=true;
        }
    }
    cout<<ans<<endl;
}
int main() {
    init();
    solve();
    return 0;
}
View Code

 


 

转载于:https://www.cnblogs.com/Rhythm-/p/9377291.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值