费马大定理

people in USSS love math very much, and there is a famous math problem .

give you two integers nn ,aa ,you are required to find 22 integers bb ,cc such that anan +bn=cnbn=cn .Inputone line contains one integer TT ;(1T1000000)(1≤T≤1000000)

next TT lines contains two integers nn ,aa ;(0n1000(0≤n≤1000 ,000000 ,000,3a40000)000,3≤a≤40000)
Outputprint two integers bb ,cc if bb ,cc exits;(1b,c1000(1≤b,c≤1000 ,000000 ,000)000) ;

else print two integers -1 -1 instead.
Sample Input

1
2 3

Sample Output

4 5
费马大定理,当n>2 时 a^n+b^n=c^n 无解
所以可以分为三种情况当n=0 题目说了 b和c必须>=1
n=1 b。c 解不唯一
当n=2 就是勾股定理了---->勾股数组
当a为大于1的奇数2n+1时,b=2n^2+2n, c=2n^2+2n+1
当a为大于4的偶数2n时,b=n^2-1, c=n^2+1
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int main()
{
    int t;
    long long n,a,b,c;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld%lld",&n,&a);
        if(n==0)
           printf("-1 -1\n");
        else if(n==1)
           printf("%lld %lld",a+1,2*a+1);
        else if(n==2)
        {
            if(a%2==1)
            {
                long long x=(a-1)/2;
                b=2*x*x+2*x;
                c=2*x*x+2*x+1;
                printf("%lld %lld\n",b,c);
            }
            if(a%2==0)
            {
                int x=a/2;
                b=x*x-1;
                c=x*x+1;
                printf("%lld %lld\n",b,c);
            }
        }
        else
          printf("-1 -1\n");
    }
    return 0;
} 

 

转载于:https://www.cnblogs.com/ylrwj/p/10746422.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值