hdu 5543 Pick The Sticks

Problem Description
The story happened long long ago. One day, Cao Cao made a special order called "Chicken Rib" to his army. No one got his point and all became very panic. However, Cao Cao himself felt very proud of his interesting idea and enjoyed it.
Xiu Yang, one of the cleverest counselors of Cao Cao, understood the command Rather than keep it to himself, he told the point to the whole army. Cao Cao got very angry at his cleverness and would like to punish Xiu Yang. But how can you punish someone because he's clever? By looking at the chicken rib, he finally got a new idea to punish Xiu Yang.
He told Xiu Yang that as his reward of encrypting the special order, he could take as many gold sticks as possible from his desk. But he could only use one stick as the container.
Formally, we can treat the container stick as an L length segment. And the gold sticks as segments too. There were many gold sticks with different length ai and value vi. Xiu Yang needed to put these gold segments onto the container segment. No gold segment was allowed to be overlapped. Luckily, Xiu Yang came up with a good idea. On the two sides of the container, he could make part of the gold sticks outside the container as long as the center of the gravity of each gold stick was still within the container. This could help him get more valuable gold sticks.
As a result, Xiu Yang took too many gold sticks which made Cao Cao much more angry. Cao Cao killed Xiu Yang before he made himself home. So no one knows how many gold sticks Xiu Yang made it in the container.


Can you help solve the mystery by finding out what's the maximum value of the gold sticks Xiu Yang could have taken?


Input
The first line of the input gives the number of test cases, T(1≤T≤100). T test cases follow. Each test case start with two integers, N(1≤N≤1000) and L(1≤L≤2000), represents the number of gold sticks and the length of the container stick. N lines follow. Each line consist of two integers, ai(1≤ai≤2000) and vi(1≤vi≤109), represents the length and the value of the ith gold stick.
 

Output
For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is the maximum value of the gold sticks Xiu Yang could have taken.
 

Sample Input

4

3 7
4 1
2 1
8 1

3 7
4 2
2 1
8 4

3 5
4 1
2 2
8 9

1 1
10 3

 

Sample Output

Case #1: 2
Case #2: 6
Case #3: 11
Case #4: 3
Hint

In the third case, assume the container is lay on x-axis from 0 to 5. Xiu Yang could put the second gold stick center at 0 and put the third gold stick center at 5,
so none of them will drop and he can get total 2+9=11 value.

In the fourth case, Xiu Yang could just put the only gold stick center on any position of [0,1], and he can get the value of 3.
题意:01背包,不过只要物品的重心在背包里就能获得它的价值,这里无论背包多大,都可以放下一个物品。

#include<cstdio>
#include<cstring>
#include<stack>
#include<vector>
#include<queue>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
const int oo = 1e9+7;
const int maxn = 1e6+7;
typedef long long LL;
int n, L;
int len[maxn];
LL val[maxn], ans, dp[5000][5];
int main()
{
    int T, i, cas=1, l, j;
    scanf("%d", &T);
    while(T--)
    {
        ans = 0;
       /// dp[j][l]表示背包容量为j时有l个物品折半放的最大价值
        memset(dp, 0, sizeof(dp));
        scanf("%d %d", &n, &L);
        L *= 2;///为了防止放置物体的时候出现浮点数 把容器与物体的长度都乘2
        for(i = 1; i <= n; i++)
        {
            scanf("%d %I64d", &len[i], &val[i]);
            ans = max(ans, val[i]);///找到价值最大的那个
            len[i] *= 2;
        }
        for(i = 1; i <= n; i++)
        {
            for(j = L; j >= len[i]/2; j--)
            {
                for(l = 0; l <= 2; l++)
                {
                    ///这里就是01背包的状态转移了
                    if(j >= len[i]) dp[j][l] = max(dp[j-len[i]][l]+val[i], dp[j][l]);
                
                    if(l && j >= len[i]/2) dp[j][l] = max(dp[j][l], dp[j-len[i]/2][l-1]+val[i]);
                }
            }
        }

        for(i = 0; i <= L; i++)
            for(j = 0; j <= 2; j++)
                ans = max(ans, dp[i][j]);
       printf("Case #%d: %I64d\n", cas++, ans);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/PersistFaith/p/4931001.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值