HDU 3999 The order of a Tree

The order of a Tree

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 66   Accepted Submission(s) : 35
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

As we know,the shape of a binary search tree is greatly related to the order of keys we insert. To be precisely:
1.  insert a key k to a empty tree, then the tree become a tree with
only one node;
2.  insert a key k to a nonempty tree, if k is less than the root ,insert
it to the left sub-tree;else insert k to the right sub-tree.
We call the order of keys we insert “the order of a tree”,your task is,given a oder of a tree, find the order of a tree with the least lexicographic order that generate the same tree.Two trees are the same if and only if they have the same shape.

Input

There are multiple test cases in an input file. The first line of each testcase is an integer n(n <= 100,000),represent the number of nodes.The second line has n intergers,k1 to kn,represent the order of a tree.To make if more simple, k1 to kn is a sequence of 1 to n.

Output

One line with n intergers, which are the order of a tree that generate the same tree with the least lexicographic.

Sample Input

4

1 3 4 2

Sample Output

1 3 2 4

Source

2011 Multi-University Training Contest 16 - Host by TJU
#include <iostream>
#include<cstdio>
using namespace std;
int ans[100005];
int i,n,k,l;
struct node
{
    int num,left,right;
}tree[100005];

void work(int k)
{
    if (k==-1) return;
    ans[++l]=tree[k].num;
    if (tree[k].left!=-1) work(tree[k].left);
    if (tree[k].right!=-1) work(tree[k].right);
}
int main()
{
    for(i=1;i<=100005;i++)
    {
        tree[i].num=-1;
        tree[i].left=-1;
        tree[i].right=-1;
    }
    scanf("%d",&n);
    if (n>=1)
        {
            scanf("%d",&k); tree[1].num=k;
            for (i=2;i<=n;i++)
            {
                scanf("%d",&k);
                tree[i].num=k;
                int t=1;
                while(1)
                {
                    while (k>tree[t].num && tree[t].right!=-1) t=tree[t].right;
                    if (k>tree[t].num && tree[t].right==-1)
                    {
                        tree[t].right=i;
                        break;
                    }
                    while (k<tree[t].num && tree[t].left!=-1) t=tree[t].left;
                    if (k<tree[t].num && tree[t].left==-1)
                    {
                        tree[t].left=i;
                        break;
                    }
                }
            }
            l=0;
            work(1);
            for(i=1;i<l;i++) printf("%d ",ans[i]);
            printf("%d\n",ans[l]);
        }
    return 0;
}

  

转载于:https://www.cnblogs.com/stepping/p/5513236.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值