The order of a Tree(模拟BST的建树和访问)

题目链接

Problem Description

As we know,the shape of a binary search tree is greatly related to the order of keys we insert. To be precisely:

  1. insert a key k to a empty tree, then the tree become a tree with
    only one node;
  2. insert a key k to a nonempty tree, if k is less than the root ,insert
    it to the left sub-tree;else insert k to the right sub-tree.
    We call the order of keys we insert “the order of a tree”,your task is,given a oder of a tree, find the order of a tree with the least lexicographic order that generate the same tree.Two trees are the same if and only if they have the same shape.

Input

There are multiple test cases in an input file. The first line of each testcase is an integer n(n <= 100,000),represent the number of nodes.The second line has n intergers,k1 to kn,represent the order of a tree.To make if more simple, k1 to kn is a sequence of 1 to n.

Output

One line with n intergers, which are the order of a tree that generate the same tree with the least lexicographic.

Sample Input

4

1 3 4 2

Sample Output

1 3 2 4

这道题的大致意思就是给你n个数,要求你给这n个数建成一颗二叉树,建树满足:1)如果这树没有结点,就插入第一个数字变为根。2),如果这树有结点,就去比较结点的大小,如果比结点小,就在该节点的左儿子结点,反之,则在右儿子结点处。
最后输出该二叉树的先序遍历。
具体代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=100010;
int pre[maxn];
int k;
struct node{
	int val;
	node *l,*r;
}; 
void add(node* &root,int &t){   //插入
	if(root==NULL){
		root=new node;
		root->val=t;
		root->l=root->r=NULL;
	}
	else {
		if(t>root->val)add(root->r,t);
		else add(root->l,t);
	}
}
void preorder(node *root){   //先序遍历
	if(root!=NULL){
		pre[k++]=root->val;
	    preorder(root->l);
	    preorder(root->r);
	}
}
void remove(node *root){   //删树
	if(root==NULL)return;
	remove(root->l);
	remove(root->r);
	delete root;
}
int main(){
	int n;
	while(cin>>n){
		node *root=NULL;
		int x;
		for(int i=1;i<=n;i++){
			scanf("%d",&x);
			add(root,x);
		}
		k=0;
		preorder(root);
		for(int i=0;i<k;i++)printf("%d%c",pre[i],i==k-1?'\n':' ');
		remove(root);
	}
}

道阻且长
自己选的路 跪着也要走完

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值