POJ 1861 - Network (最小瓶颈生成树)

题目链接 https://vjudge.net/problem/POJ-1861

Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs).
Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections.
You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied.
Input
The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 10 6. There will be no more than one way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.
Output
Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.
Sample Input
4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1
Sample Output
1
4
1 2
1 3
2 3
3 4

【题意】
给你一个N个点和M条边的图,现在要你从这M条边中选一些边的集合,使得单边的长度的最大值最小且所有N个点要连通.输出单边长度的最大值,选的边数目,每条边的两个端点号.

【思路】
最小瓶颈生成树问题是指,给出一个加权无向图,求一颗生成树,使得最大边权值尽量小。由于只关心最大权值,我们可以从一个空图开始,按照权值从小到大的顺序依次加入各条边,当图第一次连通时,对应的树即最小瓶颈生成树。而这个算法过程和kruscal算法完全一样,所以最小生成树一定是最小瓶颈生成树(反过来说不成立,最小瓶颈生成树不一定是最小生成树)。这道题目没有说一定要求一颗树,只要能将图中各点都连通即可,可以多加一些边使得图中有环存在,比如样例。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

const int maxn = 1050;
const int maxm = 15050;

struct Edge {
    int from, to, dist;
    Edge(int f = 0, int t = 0, int d = 0) :from(f), to(t), dist(d) {}
    bool operator<(const Edge& e) const {
        return dist < e.dist;
    }
};

int n, m;
int par[maxn];
bool used[maxm];
Edge edges[maxm];

int find(int x) { return par[x] == x ? x : par[x] = find(par[x]); }

void kruscal() {
    int cnt = 0, ans;
    memset(used, 0, sizeof(used));
    for (int i = 0; i <= n; ++i) par[i] = i;

    for (int i = 0; i < m && 1 + cnt < n; ++i) {
        int x = find(edges[i].from);
        int y = find(edges[i].to);
        if (x != y) {
            ++cnt;
            used[i] = true;
            par[x] = y;
            ans = edges[i].dist;
        }
    }

    printf("%d\n", ans);
    printf("%d\n", cnt);
    for (int i = 0; i < m; ++i) {
        if (used[i]) printf("%d %d\n", edges[i].from, edges[i].to);
    }
}

int main() {
    while (scanf("%d%d", &n, &m) == 2) {
        for (int i = 0; i < m; ++i) {
            int u, v, c;
            scanf("%d%d%d", &u, &v, &c);
            edges[i] = Edge(u, v, c);
        }
        sort(edges, edges + m);
        kruscal();
    }
    return 0;
}

转载于:https://www.cnblogs.com/wafish/p/10465408.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值