Drainage Ditches 分类: POJ ...

Drainage Ditches
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 62016 Accepted: 23808
Description
Every time it rains on Farmer John’s fields, a pond forms over Bessie’s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie’s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.
Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.
Sample Input
5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10
Sample Output
50
题意:John为了不让Bessie最喜欢的三叶草被雨水淹没,在农场修建了一套排水系统,将雨水排到小河里,在每个排水沟的起点安置了调节阀门,
计算排水系统的最大流水速度

#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <stdio.h>
#include <string>
#include <stack>
#include <queue>
#include <algorithm>
#include <map>
#define WW freopen("a1.txt","w",stdout)


using namespace std;

const int INF = 0x3f3f3f3f;

const int MAX = 220;

int Map[MAX][MAX];

int Dis[MAX];

int n,m;

int BFS()//通过广度优先搜索对残留网络进行分层,建立分层网络
{
    int ans;
    queue<int>Q;
    memset(Dis,-1,sizeof(Dis));
    Dis[1]=0;
    Q.push(1);
    while(!Q.empty())
    {
        ans=Q.front();
        Q.pop();
        for(int i=1;i<=n;i++)
        {
            if(Dis[i]<0&&Map[ans][i]>0)
            {
                Dis[i]=Dis[ans]+1;
                Q.push(i);
            }
        }
    }
    if(Dis[n]>0)//判断是不是能到达汇点,如果能到达汇点,则存在增广路,则要进行Dinic算法进行增广,否则就已經求出最大流
    {
        return 1;
    }
    return 0;

}
int Dinic(int x,int Min)//对分层网络进行增广,通过DFS的形式进行多次的增广
{
    if(x==n)
    {
        return Min;
    }
    int ans;

    for(int i=1;i<=n;i++)
    {
        if(Map[x][i]>0&&Dis[i]==Dis[x]+1&&(ans=Dinic(i,min(Min,Map[x][i]))))//对于x它要访问的下一个点的层次一定比它大一,一开始写成(Dis[x]==Dis[i]+1)
        {                                                                   //结果死循环。。。。。。。。。。。
            Map[x][i]-=ans;
            Map[i][x]+=ans;
            return ans;
        }
    }
    return 0;//如果到达不了汇点,则整个网络已经增广完毕,需要重新的进行分层
}
int main()
{
    int u,v,w;
    int sum;//记录最大流
    while(~scanf("%d %d",&m,&n))
    {
        memset(Map,0,sizeof(Map));
        for(int i=0;i<m;i++)
        {
            scanf("%d %d %d",&u,&v,&w);
            Map[u][v]+=w;
        }
        sum=0;
        int ans;
        while(BFS())
        {
            while(ans=Dinic(1,INF),ans)
            {
                sum+=ans;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

转载于:https://www.cnblogs.com/juechen/p/4721955.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值