Drainage Ditches (排水沟)

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

题意:M是排水沟数目,N是这些排水沟形成的汇合节点数目,0<=M<=200,2<=N<=200;结点1为池塘,N为小河,接下来有M行,每行描述了一条排水沟,三个整数来描述:Si,Ei,Ci,,水流从Si流向Ei,Ci(0<=Ci<=10 000 000)表示通过这条排水沟的最大流水速度。输出:整个排水系统可以从池塘排出水的最大速度。

思路:最大流  Edmonds-Karp算法(一种基于广度优先搜索(BFS)来计算增广路径P的算法);

最大流定理:

如果残留网络上找不到增广路径,则当前流为最大流;反之,如果当前流不为最大流,则一定有增广路径。

Code:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
typedef long long ll;
#define inf 0x3f3f3f3f
using namespace std;
ll maxflow,cap[210][210],flow[210][210],a[210],father[210];
int n,m;
void EK(int s,int e)
{
    queue<int>q;
    int u,v;
    maxflow=0;
    memset(flow,0,sizeof(flow));
    while(1)///一直循环,直到不存在增广路径
    {
        memset(a,0,sizeof(a));
        a[s]=inf;///增广量
        q.push(s);
        while(!q.empty())///bfs找增广路
        {
            u=q.front();
            q.pop();
            for(v=1;v<=m;v++)
            {
                if(a[v]==0&&cap[u][v]>flow[u][v])///当结点v还未被探索到,并且还有可用流量,找到新节点v
                {
                    father[v]=u;///记录v的父亲节点,加入queue
                    q.push(v);
                    a[v]=min(a[u],cap[u][v]-flow[u][v]);///s-v路径上的最小残量
                }
            }
        }
        if(a[e]==0)break;///找不到,则当前流已经是最大流
        for(u=e;u!=s;u=father[u])///从汇点往回走
        {
            flow[father[u]][u]+=a[e];///更新前向弧流量
            flow[u][father[u]]-=a[e];///更新后向弧流量
        }
        maxflow+=a[e];///更新从s流出的总流量
    }
}
int main()
{
    while(~scanf("%d %d",&n,&m))///n条边,m个节点
    {
        memset(cap,0,sizeof(cap));
        int s,e;
        ll c;
        for(int i=0;i<n;i++)
        {
            scanf("%d %d %lld",&s,&e,&c);
            cap[s][e]+=c;///有重边
        }
        EK(1,m);
        printf("%lld\n",maxflow);
    }
    return 0;
}

附图:

嘿嘿~

接触网络流的第一道题!

择其善者而从之,其不善者而改之!~

虽然学长学姐们都说网络流超难理解~

but~好好学~一定会学好的~

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

嵩韵儿

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值