Drainage Ditches (dinic)



Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.
Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.
Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

题意求1到m的最大流。dinic算法比ek少了对未联通边判断的过程
算法过程
   1,用BFS建立分层图  注意:分层图是以当前图为基础建立的,所以要重复建立分层图
   2,用DFS的方法寻找 一条由源点到汇点的路径,获得这条路径的流量I 根据这条路径修改整个图 ,
        将所经之处正向边流量减少I,反向边流量增加I,注意I是非负数
   3,重复步骤2,直到DFS找不到新的路径时,重复步骤。
   PS:Dinic中DFS时只在分层图中DFS,意思是说DFS的下一个节点的Dis(距源点的距离)要比自己的Dis大1
        “获得这条路径的流量I “实现:DFS函数有参量u,代表从源点到现在最窄的(剩余流量最小)的边的剩余流量,当DFS到汇点    是,Low便是我们要的流量I
代码:
#include <cstdio>
#include <cstring>
#include <string>
#include <map>
#include <stack>
#include <cmath>
#include <queue>
#include <vector>
#include <iostream>
#include <algorithm>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3f
const int maxn=300;
int e[maxn][maxn];
int dis[maxn];//离原点距离
int n,m;
int bfs()
{
    memset(dis,0,sizeof(dis));
    queue<int >q;
    while(!q.empty()){q.pop();}
    q.push(1);
    dis[1]=1;
    while(!q.empty())
    {
        int now=q.front();
        q.pop();
        for(int i=1;i<=m;i++)
        {
            if(!dis[i]&&e[now][i]>0)
            {
                dis[i]=dis[now]+1;
                q.push(i);
            }
        }
    }
    if(dis[m]) return 1;
    return 0;
}
int dfs(int s,int u)
{
    if(s==m) return u;
    int tmp=u;
    for(int i=1;i<=m&&tmp;i++)
    {
        if(dis[i]==dis[s]+1&&e[s][i]>0)
        {
            int t=dfs(i,min(e[s][i],tmp));
            e[s][i]-=t;
            e[i][s]+=t;
            tmp-=t;;//从源点到s的瓶颈也会更小(减少t )
        }
    }
    return u-tmp;
}
int dinic()
{
    int t=0,ans=0;
    while(bfs())
    {
        while(t=dfs(1,inf))
            ans+=t;
    }
    return ans;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(e,0,sizeof(e));
        for(int i=0;i<n;i++)
        {
            int a,b,v;
            scanf("%d%d%d",&a,&b,&v);
            e[a][b]+=v;
        }
       cout<<dinic()<<endl;
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值