The kth great number(hdu4006+优先队列)

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.

Input

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 

Output

The output consists of one integer representing the largest number of islands that all lie on one line. 

Sample Input

8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q

Sample Output

1
2
3

Hint

Xiao  Ming  won't  ask  Xiao  Bao  the  kth  great  number  when  the  number  of  the  written number is smaller than k. (1=<k<=n<=1000000).

I加入一个数

Q询问第k大的数值

这道题用优先队列做

队列升序

用队首保存第k大的数,第k大数也是k个有序数了最小的数

每次压入后,如果队列元素大于k,就弹出最小的呢个数

ac:

#include<cstdio>
#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;

int main()
{
    char ctr[2];
    int n,m,d;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        priority_queue<int,vector<int>,greater<int>> que;
        for(int i=0;i<n;i++)
        {
            scanf("%s",&ctr);
            if(ctr[0]=='I')
            {
                scanf("%d",&d);
                que.push(d);
                if(que.size()>m)
                    que.pop();
            }
            else{
                printf("%d\n",que.top());
            }
        }
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/wangtao971115/p/10358253.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值