HDU 4006 The kth great number (基本算法-水题)

The kth great number


Problem Description
Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
 

Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 
 

Output
The output consists of one integer representing the largest number of islands that all lie on one line. 
 

Sample Input
 
  
8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q
 

Sample Output
 
  
1 2 3
Hint
Xiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).
 

Source
 

Recommend
lcy
 


题目大意:

有m组操作,求第K大数。I为insert操作,即插入1个数,Q为询问,输出此时的第K大数。


解题思路:

一道水题让我智商捉鸡了,居然笨到想去用线段树去做。后来发现1个set搞定,就存K个大数,超过的把小的踢掉,输出第一个即可。


解题代码:

#include <iostream>
#include <cstdio>
#include <set>
#include <algorithm>
using namespace std;

int n,k;
multiset <long long> mys;

void solve(){
    mys.clear();
    char ch;
    int x;
    for(int i=0;i<n;i++){
        scanf("\n");
        scanf("%c",&ch);
        if(ch=='I'){
            scanf("%lld",&x);
            mys.insert(x);
            if(mys.size()>k) mys.erase(mys.begin());
        }else{
            cout<<*mys.begin()<<endl;
        }
    }
}

int main(){
    while(scanf("%d%d",&n,&k)!=EOF){
        solve();
    }
    return 0;
}




转载于:https://www.cnblogs.com/toyking/p/3893177.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值