蓝桥杯练习【STL训练】——The kth great number

题目描述:

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.

输入:

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.

输出:

The output consists of one integer representing the largest number of islands that all lie on one line.

样例输入:

8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q

样例输出:

1
2
3

解题思路:

使用优先级队列小根堆,始终保持队列里面是当前最大的k个数。

参考代码:

#include<bits/stdc++.h>

using namespace std;

priority_queue<int, vector<int>, greater<int> >a;

int main () {
  char ch;
  int n,k;
  while (~scanf("%d%d",&n,&k)) {
    while (!a.empty())
        a.pop();
    while (n--) {
      int num;
      getchar();
      scanf("%c", &ch);
      if (ch == 'I') {
        scanf("%d",&num);
        a.push(num);
        if(a.size()>k)
        a.pop();
      }else {
        num = a.top();
        printf("%d\n",num);
      }
    }
  }
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值