poj2965 The Pilots Brothers' refrigerator

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4
这道题和翻黑白棋差不多,用深搜可以做,不同的是要记录每次的路径,可以设个数组b[][].
#include<stdio.h>
#include<string.h>
int step,flag;
char s[10][10];
int b[20][2];
int panduan(char s[10][10]){
	int i,j;
	for(i=0;i<4;i++){
		for(j=0;j<4;j++){
			if(s[i][j]=='+')return 0;
		}
	}
	return 1;
}


void flip(int row,int col)
{
	int i,j;
	for(i=0;i<=3;i++){
		if(s[i][col]=='+')s[i][col]='-';
		else s[i][col]='+';
	}
	for(i=0;i<=3;i++){
		if(s[row][i]=='+')s[row][i]='-';
		else s[row][i]='+';
	}
	if(s[row][col]=='+')s[row][col]='-';
		else s[row][col]='+';
	return;
}


void dfs(int row,int col,int dep)
{
	int i,j;
	if(flag)return;
	if(dep==step){
		flag=panduan(s);return;
	}
	if(flag || row==4)return;
	
	flip(row,col);
	if(col<3){
		b[dep+1][0]=row;
		b[dep+1][1]=col;
		dfs(row,col+1,dep+1);
	}
	else{
		b[dep+1][0]=row;
		b[dep+1][1]=col;
		dfs(row+1,0,dep+1);
	}
	if(flag)return;
	
	flip(row,col);
	if(col<3){
		dfs(row,col+1,dep);
	}
	else dfs(row+1,0,dep);
	return;
}


int main()
{
	int n,m,i,j;
	while(scanf("%s",s[0])!=EOF)
	{
		for(i=1;i<=3;i++){
			scanf("%s",s[i]);
		}
		for(step=1;step<=16;step++){
			memset(b,0,sizeof(b));
			flag=0;
			dfs(0,0,0);
			if(flag)break;
		}
		printf("%d\n",step);
		for(i=1;i<=step;i++){
			printf("%d %d\n",b[i][0]+1,b[i][1]+1);
		}
	}
	return 0;
} 

转载于:https://www.cnblogs.com/herumw/p/9464826.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值