A+B problem II

A + B Problem II

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 108   Accepted Submission(s) : 21
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

主要代码如下

if(A>=B)
        {
            for(i=A-1,j=B-1;i>=0;i--,j--)
            {
                if(j>=0)
                    a[i]=a[i]+(b[j]-'0');//清零的过程
                if(a[i]>'9')
                {
                    a[i]=a[i]-('9'-'/');
                    if((i-1)>=0)
                        a[i-1]=a[i-1]+('1'-'0');
                    else
                        t=t+('1'-'0');
                }
            }


整个程序

#include <iostream>
#include<cstring>
using namespace std;
int main()
{
    char a[1001],b[1001],t;  //输入
    int n,i,j,k,A,B;
    cin>>n;
    k=n;
    while(n--)
    {
        t='0';
        cin>>a>>b;
        A=strlen(a);
        B=strlen(b);
        cout<<"Case"<<" "<<k-n<<":"<<endl<<a<<" "<<"+"<<" "<<b<<" "<<"= ";   //输出
        if(A>=B)
        {
            for(i=A-1,j=B-1;i>=0;i--,j--)
            {
                if(j>=0)
                    a[i]=a[i]+(b[j]-'0');
                if(a[i]>'9')
                {
                    a[i]=a[i]-('9'-'/');
                    if((i-1)>=0)
                        a[i-1]=a[i-1]+('1'-'0');
                    else
                        t=t+('1'-'0');
                }
            }

            if(t>'0'&&t<='9')
                cout<<t<<a<<endl;
            else
                cout<<a<<endl;
            
        }
        else
        {
            for(i=A-1,j=B-1;j>=0;i--,j--)
            {
                if(i>=0)
                    b[j]=b[j]+(a[i]-'0');
                if(b[j]>'9')
                {
                    b[j]=b[j]-('9'-'/');
                    if((j-1)>=0)
                        b[j-1]=b[j-1]+('1'-'0');
                    else
                        t=t+('1'-'0');
                }
            }
            if(t>'0'&&t<='9')
                cout<<t<<b<<endl;
            else
                cout<<b<<endl;
            
        }
        if(n!=0)
            cout<<endl;
        
    }
    
    return 0;
}


 

转载于:https://www.cnblogs.com/u013533289/p/4477341.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值