hdu 3018 Ant Trip 欧拉回路+并查集

Ant Trip

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
Ant Country consist of N towns.There are M roads connecting the towns.

Ant Tony,together with his friends,wants to go through every part of the country.

They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people.So they are trying to divide all the people into several groups,and each may start at different town.Now tony wants to know what is the least groups of ants that needs to form to achieve their goal.
 

 

Input
Input contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0<=M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each line contains two integers a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.
 

 

Output
For each test case ,output the least groups that needs to form to achieve their goal.
 

 

Sample Input
3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

 

Sample Output
1 2
Hint
New ~~~ Notice: if there are no road connecting one town ,tony may forget about the town. In sample 1,tony and his friends just form one group,they can start at either town 1,2,or 3. In sample 2,tony and his friends must form two group.
 

 

Source
题意:给你n个城市,m条边,一个人只能走他没有走过的路,问最少几个人才能把路走完;
思路:相当于只需要求有多少条欧拉路径,利用并查集判联通,如果一个图联通的并且含有n个奇数度的点,那么需要走n/2,因为一条欧拉路径最多两个奇数点;
#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define mod 1000000007
#define esp 0.00000000001
const int N=1e5+10,M=1e6+10,inf=1e9;
const ll INF=1e18+10;
int n,m;
int fa[N],du[N],flag[N],mark[N],hh[N];
int Find(int x)
{
    return fa[x]==x?x:fa[x]=Find(fa[x]);
}
void update(int u,int v)
{
    int x=Find(u);
    int y=Find(v);
    if(x!=y)
    {
        fa[x]=y;
    }
}
void init()
{
    for(int i=0;i<N;i++)
        fa[i]=i;
    memset(flag,0,sizeof(flag));
    memset(du,0,sizeof(du));
    memset(mark,0,sizeof(mark));
    memset(hh,0,sizeof(hh));
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        init();
        for(int i=1;i<=m;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            update(u,v);
            du[u]++;
            du[v]++;
            hh[u]=1;
            hh[v]=1;
        }
        int ans=0,sum=0;
        for(int i=1;i<=n;i++)
        {
            if(!hh[i])continue;
            int x=Find(i);
            du[i]%=2;
            sum+=du[i];
            if(!flag[x])
            {
                ans++;
                flag[x]=1;
            }
            if(du[i]==1&&flag[x]&&!mark[x])
            {
                ans--;
                mark[x]=1;
            }
        }
        printf("%d\n",ans+sum/2);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/jhz033/p/6114959.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值