【HDU Ant Trip】 欧拉图 + 并查集

22 篇文章 0 订阅
9 篇文章 0 订阅

Ant Country consist of N towns.There are M roads connecting the towns.

Ant Tony,together with his friends,wants to go through every part of the country.

They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people.So they are trying to divide all the people into several groups,and each may start at different town.Now tony wants to know what is the least groups of ants that needs to form to achieve their goal.

Input
Input contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0<=M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each line contains two integers a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.

Output
For each test case ,output the least groups that needs to form to achieve their goal.

Sample Input
3 3
1 2
2 3
1 3

4 2
1 2
3 4

Sample Output
1
2

Hint

New ~~~ Notice: if there are no road connecting one town ,tony may forget about the town.
In sample 1,tony and his friends just form one group,they can start at either town 1,2,or 3.
In sample 2,tony and his friends must form two group.

题意:给一个图,每个点只能走一次,问要多少次一笔画才能走完

思路:

很典型的一笔画问题,欧拉图了。
欧拉图性质:
1.若一条路上的点的度数都为偶数,那么它为一个欧拉路径(图),可以一笔画完。
2.非(半)欧拉图需要的笔数==该图中奇数度的点数目/2。
那么就只用看每个结点的度数即可。
详见代码注释:

#include <iostream>
#include <string>
#include <time.h>
#include <vector>
#include <map>
#include <queue>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <cstdio>
#include <set>
#define maxn 100000+500
using namespace std;
int root[maxn];
int father[maxn];
int du[maxn];
int num[maxn];
int n, m;

int get(int x)          //并查集
{
    if(father[x]==x) return x;
    return father[x] = get(father[x]);      //压缩路径
}

void merge(int x, int y)
{
    int a = get(x);
    int b = get(y);
    if(a!=b)
    {
        father[b] = a;
    }
}

void init()     //初始化
{
      memset(du,0,sizeof(du));
      memset(num,0,sizeof(num));
      memset(root,0,sizeof(root));
      for(int i=1;i<=n;i++)
      father[i] = i;
}

int main()
{
    while(cin>>n>>m)
    {
        init();
        for(int i=1;i<=m;i++)
        {
                int x, y;
                scanf("%d%d",&x,&y);
                merge(x,y);
                du[x]++;        //点度数++
                du[y]++;
        }
        for(int i=1;i<=n;i++)
        {
                num[get(i)]++;      //看看根节点带着多少结点
                if(du[i]&1)  root[get(i)]++;        //记录度数为奇数的点,以get(i)为根的联通分量中奇点的个数
        }
        int ans = 0;
        for(int i=1;i<=n;i++)
        {
            if(num[i]<=1) continue;     //num为0的是不存在的点,为1的是孤立的点
            else if(root[i]==0)  ans++;     //该点引导的路径上的点度数全为偶数,一笔画
            else  ans += root[i]/2;     //否则就要root[i]/2步画完
        }
        cout<<ans<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值