Kindergarten

传送门:http://poj.org/problem?id=3692

Language:
Kindergarten
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6831 Accepted: 3374
Description

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.

Input

The input consists of multiple test cases. Each test case starts with a line containing three integers
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.

Sample Input

2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0
Sample Output

Case 1: 3
Case 2: 4
Source

2008 Asia Hefei Regional Contest Online by USTC

【解析】

题意:女孩们都互相认识,男孩们也都互相认识。有些男孩女孩互相认识,选出人数最多的互相认识的团体。

解法:求二分图的最大独立集。

如果我们选出的这些人两两互相认识,说明在一个图中这些点两两之间有连线,我们怎样找到这样一个图呢。

我们利用二分图的性质,将不认识的人连线。求最大独立集。最大独立集就是这个集合中的所有点两两之间没有连线。

没有连线就是互相认识。

最大独立集=所有的顶点个数-最大匹配。

【code】

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 200+10
int map[N][N],match[N];
bool vis[N];
int x,y,g,b,m,cnt,tim;
bool path(int x)
{
    for(int i=1;i<=b;i++)
    {
        if(!vis[i]&&!map[x][i])
        {
        vis[i]=1;
        if(!match[i]||path(match[i]))
        {
            match[i]=x;
            return true;
        }
        }    
    }
    return false;
}
int main()
{
    while(scanf("%d%d%d",&g,&b,&m)&&g&&b&&m)
    {
        cnt=0;//*注意清0 
        tim++;
        memset(match,0,sizeof(match));
        memset(map,0,sizeof(map));
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&x,&y);
            map[x][y]=1;                          
        }
        for(int i=1;i<=g;i++)
        {
            memset(vis,0,sizeof(vis));
            if(path(i))
            cnt++;            
        }    
        printf("Case %d: %d\n",tim,g+b-cnt);
    }
    return 0;
 } 

 

转载于:https://www.cnblogs.com/zzyh/p/6842465.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值