HDU-2458 Kindergarten

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.

Input

The input consists of multiple test cases. Each test case starts with a line containing three integers
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.

Sample Input

2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0

Sample Output

Case 1: 3
Case 2: 4

题目大意:

   一群小朋友,男的认识全部的男的,部分女生,女生认识全部的女生,认识部分男生,求最后能最多找出多少人,使得他们互相都认识。

解题思路:

        建图时互相不认识的为一个链接,就是求不认识的最小覆盖数即完美匹配数,从g + b中减去它即可。

代码:

#include <stdio.h>
#include <string.h>
int map[210][210];
int match[210];
int book[210];
int b;

int dfs(int v)
{
	int i;
	for(i=1;i<=b;i++)
	{
		if(book[i]==0&&map[v][i]==1)
		{
			book[i]=1;
			if(match[i]==0||dfs(match[i]))
			{
				match[i]=v;
				return 1;
			}
		}
	}
	return 0;
}

int main()
{
	int i,j,ans,x,y,g,m,t=1;
	while(scanf("%d%d%d",&g,&b,&m)!=EOF)
	{
		if(g==0&&b==0&&m==0)
			break;
		for(i=1;i<=g;i++)
			for(j=1;j<=b;j++)
				map[i][j]=1;
		memset(book,0,sizeof(book));
		memset(match,0,sizeof(match));
		for(i=1;i<=m;i++)
		{
			scanf("%d%d",&x,&y);
			map[x][y]=0;
		}
		ans=0;
		for(i=1;i<=g;i++)
		{
			memset(book,0,sizeof(book));
			if(dfs(i)==1)
				ans++;
		}
		printf("Case %d: %d\n",t++,g+b-ans);
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值