Squares-暴力枚举或者二分

B - Squares
Time Limit:3500MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property. 

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates. 

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1
/*
Author: 2486
Memory: 24256 KB		Time: 375 MS
Language: C++		Result: Accepted
*/
//此题目暴力暴力枚举
//通过已经确定好的两点,算出剩下的两点
//(有两种情况)
//一个在上面,一个以下
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=20000+5;
struct point{
    int x,y;
}ps[1005];
int n,ans;
bool vis[maxn<<1][maxn<<1];
int main(){
while(~scanf("%d",&n),n){
    ans=0;
    for(int i=0;i<n;i++){
        scanf("%d%d",&ps[i].x,&ps[i].y);
        ps[i].x+=20000,ps[i].y+=20000;//在数组里面能够存储负数
        vis[ps[i].x][ps[i].y]=true;//标记着这个点存在
    }
    for(int i=0;i<n;i++){
        for(int j=0;j<i;j++){
            if(i==j)continue;//分别代表着上下两种不同的正方形
            int nx1=ps[i].x+ps[i].y-ps[j].y;
            int ny1=ps[i].y+ps[j].x-ps[i].x;
            int nx2=ps[j].x+ps[i].y-ps[j].y;
            int ny2=ps[j].y+ps[j].x-ps[i].x;
            if(vis[nx1][ny1]&&vis[nx2][ny2])ans++;
            nx1=ps[i].x-(ps[i].y-ps[j].y);
            ny1=ps[i].y-(ps[j].x-ps[i].x);
            nx2=ps[j].x-(ps[i].y-ps[j].y);
            ny2=ps[j].y-(ps[j].x-ps[i].x);
            if(vis[nx1][ny1]&&vis[nx2][ny2])ans++;
        }
    }
    for(int i=0;i<n;i++){
        vis[ps[i].x][ps[i].y]=false;//必需要进行清零,不能用memset,由于数组有点大
    }
    printf("%d\n",ans/4);
}
return 0;
}


转载于:https://www.cnblogs.com/lytwajue/p/6971114.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值