poj2551

1.链接地址

https://vjudge.net/problem/POJ-2551

2.问题描述

 Given any integer 0 <= n <= 10000 not divisible by 2 or 5, some multiple of n is a number which in decimal notation is a sequence of 1's. How many digits are in the smallest such a multiple of n?

输入样例

3 
7 
9901

输出样例

3
6
12

3.解题思路

 题意即存在一个只由1组成的数,可以整除给出的n。注意不要超出位数

4.算法实现源代码

#include<cstdio>
#include<cstdlib>
#include<iostream>
using namespace std;
int main()
{
    int i,j,n;
    bool f;
    int s,t=0;
    while(scanf("%d",&n)!=EOF)
    {
        f=false;
        t=s=1;
        t=t%n;
        while(t!=0)
        {
            t=(t*10%n+1)%n;
            s++;
        }
        printf("%d\n",s);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/KasenBob/p/11176926.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值