HDU 4004The Frog's Games(二分)

117 篇文章 0 订阅
7 篇文章 0 订阅
Description
The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).

Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m.
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.

Output
For each case, output a integer standing for the frog's ability at least they should have.

Sample Input
6 1 2
2
25 3 3
11
2
18

Sample Output
4

11

题意:一只青蛙想要跳到对岸。已知河里有n块石头,石头的位置,两边河岸距离,还有青蛙能跳几次。问青蛙能跳过去的过程中跳的最大距离的最小值。
思路:二分法,先找到青蛙可以跳的最优解,然后在用二分法找到最优解中的最大距离的最小值。保存每次青蛙跳的最后一个石头,在用这个石头判断是否能跳到对岸。
代码:
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<math.h>
#define xps 1e-12
using namespace std;
long long l,n,t,ans;
long long a[500010];
bool judge(int x)
{
	int cnt=0;
	int last=0;
	for(int i=0;i<=n;)
	{
		if(a[i]<=last+x)
		i++;
		else
		{
			if(last==a[i-1])
			return false;
			last=a[i-1];
			cnt++;
		}
	}
	cnt++;
	return cnt<=t;
}
int main()
{
	while(scanf("%d%d%d",&l,&n,&t)!=EOF)
	{
		for(int i=0;i<n;i++)
		scanf("%d",&a[i]);
		a[n]=l;
		sort(a,a+n);
		int s=1,e=l,mid;
		while(s<=e)
		{
		mid=(s+e)/2;
		if(judge(mid))
		{
			ans=mid;
			e=mid-1;
			}
			else
			s=mid+1;	
		}
		printf("%lld\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值