poj 3980 取模运算

取模运算
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6776 Accepted: 4182

Description

编写一个C函数mod(int n, int m),实现取模运算%

Input

输入包含多行数据

每行数据是两个整数a, b (1 <= a, b <= 32767)
数据以EOF结束

Output

于输入的每一行输出a%b

Sample Input

5 3
100 2

Sample Output

2
0
#include<stdio.h>
int mod(int n, int m)
{
if(n<m)
return n;
return n-(n/m)*m;
}
int main()
{
int n,m;
while(scanf("%d %d",&n,&m)!=EOF)
printf("%d\n",mod(n,m));
return 0;
}
 

转载于:https://www.cnblogs.com/w0w0/archive/2011/11/23/2259987.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值