Eddy's picture

Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you. Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?
 
Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.
Input contains multiple test cases. Process to the end of file.
 
Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.
 
Sample Input
3 1.0 1.0 2.0 2.0 2.0 4.0
 
Sample Output
3.41
prim算法:
#include<iostream>
#include<math.h>
using namespace std;
#define Max 100000
#include<string.h>
double flag[105][105];
int visit[105];
double ans[105];
struct lmx{
 double x;
 double y;
};
lmx lm[105];
double cnt(lmx s,lmx t)
{
 return sqrt((s.x-t.x)*(s.x-t.x)+(s.y-t.y)*(s.y-t.y));
}
double prim(int n)
{
 memset(visit,0,sizeof(visit));
 int i,pos,k=n-1;
 double min=Max;
 visit[0]=1;
 double sum=0;
 memset(ans,Max,sizeof(ans));
 for(i=1;i<n;i++)
 {
       ans[i]=flag[0][i];
 }
 while(k--)
 {
  min=Max;
  for(i=0;i<n;i++)
  {
   if(visit[i]==0&&ans[i]<min)
   {
                  min=ans[i];
      pos=i;
   }
  }
  visit[pos]=i;
  sum+=min;
  for(i=0;i<n;i++)
  {
   if(visit[i]==0&&flag[pos][i]<ans[i])  ans[i]=flag[pos][i];
  }
 }
     return sum;
}
int main()
{
    int n,i,j;
 cout.precision(2);
 while(cin>>n)
 {
  for(i=0;i<n;i++) cin>>lm[i].x>>lm[i].y;
  for(i=0;i<n;i++)
  {
   for(j=0;j<n;j++)
   {
    if(i!=j)  flag[i][j]=cnt(lm[i],lm[j]);
    else flag[i][j]=Max;
   }
  }
        cout<<fixed<<prim(n)<<endl;
 }
 return 0;
}

转载于:https://www.cnblogs.com/ffhuguang/archive/2013/04/01/2992601.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值