Restoring Road Network 反证最短路

问题 C: Restoring Road Network

时间限制: 1 Sec  内存限制: 128 MB
提交: 438  解决: 89
[提交] [状态] [讨论版] [命题人:admin]

题目描述

In Takahashi Kingdom, which once existed, there are N cities, and some pairs of cities are connected bidirectionally by roads. The following are known about the road network:
People traveled between cities only through roads. It was possible to reach any city from any other city, via intermediate cities if necessary.
Different roads may have had different lengths, but all the lengths were positive integers.
Snuke the archeologist found a table with N rows and N columns, A, in the ruin of Takahashi Kingdom. He thought that it represented the shortest distances between the cities along the roads in the kingdom.
Determine whether there exists a road network such that for each u and v, the integer Au,v at the u-th row and v-th column of A is equal to the length of the shortest path from City u to City v. If such a network exist, find the shortest possible total length of the roads.

Constraints
1≤N≤300
If i≠j, 1≤Ai,j=Aj,i≤109.
Ai,i=0

 

输入

Input is given from Standard Input in the following format:
N
A1,1 A1,2 … A1,N
A2,1 A2,2 … A2,N

AN,1 AN,2 … AN,N
 

 

输出

If there exists no network that satisfies the condition, print -1. If it exists, print the shortest possible total length of the roads.

 

样例输入

3
0 1 3
1 0 2
3 2 0

 

样例输出

3

 

提示

The network below satisfies the condition:
City 1 and City 2 is connected by a road of length 1.
City 2 and City 3 is connected by a road of length 2.
City 3 and City 1 is not connected by a road.

这个题一开始读了很久没理解题意,后来好不容易觉得自己读懂了(给点之间的距离,求最短路),赶紧拿floyd开始写,写了半天觉得怪怪的,输出的矩阵里和输入一模一样,一开始怀疑代码有bug,后来de了半天也没发现,只好重新读题

最后才搞明白输入的数据是最短路的矩阵,证明这个最短路是不是合法(我是这样理解的,如果是错的,希望指出),如果是,输出最短的边距离,否则输出-1

大概Floyd思想,如果mapp[i][j]>mapp[i][k]+mapp[k][j],则证明不合法

                          如果mapp[i][j]=mapp[i][k]+mapp[k][j],那么i到j可以不需要k这个中间点

代码:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxx=500;
const int INF=1e9+100;
const int MOD=1e9+7;
int n;
ll mapp[maxx][maxx];
int main()
{
    scanf("%d",&n);
    for(int i=1; i<=n; i++){
        for(int j=1; j<=n; j++){
            scanf("%lld",&mapp[i][j]);
        }
    }
    ll ans=0;
    int flag;
    for(int i=1; i<=n; i++){
        for(int j=1; j<=n; j++){
            if(i==j)  continue;
            flag=1;
            for(int k=1; k<=n; k++){
                if(i==k || j==k) continue;
                if(mapp[i][j]>mapp[i][k]+mapp[k][j]){
                    cout<<"-1"<<endl;
                    return 0;
                }
                if(mapp[i][j]==mapp[i][k]+mapp[k][j]){
                    flag=0;
                }
            }
            if(flag) ans+=mapp[i][j];
        }
    }
    printf("%lld\n",ans/2);
    return 0;
}

 

转载于:https://www.cnblogs.com/renxiaomiao/p/9642678.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
### 内容概要 《计算机试卷1》是一份综合性的计算机基础和应用测试卷,涵盖了计算机硬件、软件、操作系统、网络、多媒体技术等多个领域的知识点。试卷包括单选题和操作应用两大类,单选题部分测试学生对计算机基础知识的掌握,操作应用部分则评估学生对计算机应用软件的实际操作能力。 ### 适用人群 本试卷适用于: - 计算机专业或信息技术相关专业的学生,用于课程学习或考试复习。 - 准备计算机等级考试或职业资格认证的人士,作为实战演练材料。 - 对计算机操作有兴趣的自学者,用于提升个人计算机应用技能。 - 计算机基础教育工作者,作为教学资源或出题参考。 ### 使用场景及目标 1. **学习评估**:作为学校或教育机构对学生计算机基础知识和应用技能的评估工具。 2. **自学测试**:供个人自学者检验自己对计算机知识的掌握程度和操作熟练度。 3. **职业发展**:帮助职场人士通过实际操作练习,提升计算机应用能力,增强工作竞争力。 4. **教学资源**:教师可以用于课堂教学,作为教学内容的补充或学生的课后练习。 5. **竞赛准备**:适合准备计算机相关竞赛的学生,作为强化训练和技能检测的材料。 试卷的目标是通过系统性的题目设计,帮助学生全面复习和巩固计算机基础知识,同时通过实际操作题目,提高学生解决实际问题的能力。通过本试卷的学习与练习,学生将能够更加深入地理解计算机的工作原理,掌握常用软件的使用方法,为未来的学术或职业生涯打下坚实的基础。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值