Contest1392 - 2018年第三阶段个人训练赛第七场. Restoring Road Network(最短路径 Floyd算法)

问题 C: Restoring Road Network

时间限制: 1 Sec  内存限制: 128 MB
提交: 790  解决: 161
[提交] [状态] [讨论版] [命题人:admin]

题目描述

In Takahashi Kingdom, which once existed, there are N cities, and some pairs of cities are connected bidirectionally by roads. The following are known about the road network:
People traveled between cities only through roads. It was possible to reach any city from any other city, via intermediate cities if necessary.
Different roads may have had different lengths, but all the lengths were positive integers.
Snuke the archeologist found a table with N rows and N columns, A, in the ruin of Takahashi Kingdom. He thought that it represented the shortest distances between the cities along the roads in the kingdom.
Determine whether there exists a road network such that for each u and v, the integer Au,v at the u-th row and v-th column of A is equal to the length of the shortest path from City u to City v. If such a network exist, find the shortest possible total length of the roads.

Constraints
1≤N≤300
If i≠j, 1≤Ai,j=Aj,i≤109.
Ai,i=0

 

输入

Input is given from Standard Input in the following format:
N
A1,1 A1,2 … A1,N
A2,1 A2,2 … A2,N

AN,1 AN,2 … AN,N
 

 

输出

If there exists no network that satisfies the condition, print -1. If it exists, print the shortest possible total length of the roads.

 

样例输入

3
0 1 3
1 0 2
3 2 0

 

样例输出

3

 

提示

The network below satisfies the condition:
City 1 and City 2 is connected by a road of length 1.
City 2 and City 3 is connected by a road of length 2.
City 3 and City 1 is not connected by a road.

题目大意:有一个 N*N 的矩阵,每一行 i 和 每一列 j 对应的坐标表示从 i 点到 j 点的路径距离,路径是双向的。判断所给路径是否为从 i 到 j 的最短路径,如果不是输出 -1;如果是则求出所需路径的最小距离。

解题思路:因为 N 数值较小,因此我们先用 Floyd 算法求出每两点中转路径之间的最短距离(不包含直接从 i 到 j 的路径),然后遍历所有路径。如果存在中转路径比直接路径数值小,则输出 -1;如果中转路径比直接路径大,我们加上直接路径的距离;如果相等,因为题目要求最小距离,所以不操作,直接进入下一个循环。

参考代码:

#include<bits/stdc++.h>
using namespace std;
long long a[310][310];
int main()
{
    int n;
    while(cin>>n)
    {
        int flg=0;
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                cin>>a[i][j];
        long long ans=0;
        for(int i=1; i<=n; i++)
            for(int j=i+1; j<=n; j++)
            {
                long long ans1=0x3f3f3f3f;
                for(int k=1; k<=n; k++){
                    if(k==i||k==j) continue;
                    ans1=min(a[i][k]+a[k][j],ans1);
                }
                if(ans1==a[i][j]) continue;
                if(ans1>a[i][j]) ans+=a[i][j];
                if(ans1<a[i][j]) flg=1;
            }
        if(flg) cout<<-1<<endl;
        else
            cout<<ans<<endl;
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值