poj 3687 拓扑排序

      

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4
题意:有n个球重量分别1到n;对每个球进行编号,给出编号之间的重量大小,按重量排序从小到大(让编号小的尽可能重量小)。
这题意有点绕,wrong了好几次,以5—>6->1,4->3->2为例,正确的顺序应该是5 6 1 4 3 2,而不是4 3 2 5 6 1;难点在于让编号小的排在前面;
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
const int N=210;
int n,deep[N],topo[N];
bool map[N][N];
int toposort()
{
   int temp[N],c=0,k,m,i,j;
   for(i=0;i<=n;i++)
   {
       temp[i]=deep[i];
   }
   for(i=n;i>0;i--)
   {
       m=0;
       for(j=n;j>0;j--)
       {
           if(temp[j]==0){m++;k=j;break;}
       }
       if(m==0) return 0;
       topo[k]=i;
       temp[k]=-1;
       for(j=1;j<=n;j++)
       {
           if(map[k][j]==1)
           {
               temp[j]--;
           }
       }
   }
   return 1;
}
int main()
{
    int t,m,i,x,y;
    scanf("%d",&t);
    while(t--)
    {
        memset(map,0,sizeof(map));
        memset(deep,0,sizeof(deep));
        scanf("%d%d",&n,&m);
        for(i=1;i<=m;i++)
        {
            scanf("%d%d",&x,&y);
            if(!map[y][x])
            {
                deep[x]++;
            }
            map[y][x]=1;
        }
        int sign=toposort();
        if(!sign)
           printf("-1");
        else
        for(i=1;i<=n;i++)
        {
            if(i==1)
               printf("%d",topo[i]);
             else
                printf(" %d",topo[i]);
        }
        printf("\n");
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/yuanbo123/p/4840738.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值